# CVE-2022-1982: A crafted SVG attachment can crash a Mattermost server

> An authenticated attacker can crash the Mattermost server by uploading a crafted SVG attachment, causing a denial of service.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2022
- **Updated:** 6 Dec 2024
- **Also known as:** BIT-mattermost-2022-1982, GHSA-gwpf-95jc-63rv

## What is CVE-2022-1982?

CVE-2022-1982 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 2 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Uncontrolled resource consumption in Mattermost version 6.6.0 and earlier allows an authenticated attacker to crash the server via a crafted SVG attachment on a post.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-1982?

9 open source packages ship an affected version, including github.com/mattermost/mattermost-server and mattermost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 5.0.0 | 6.3.8 |
| `github.com/mattermost/mattermost-server` | Go | From 5.0.0 | 6.3.8 |
| `github.com/mattermost/mattermost-server` | Go | From 6.4.0 | 6.4.3 |
| `github.com/mattermost/mattermost-server` | Go | From 6.4.0 | 6.4.3 |
| `github.com/mattermost/mattermost-server` | Go | From 6.5.0 | 6.5.1 |
| `github.com/mattermost/mattermost-server` | Go | From 6.5.0 | 6.5.1 |
| `github.com/mattermost/mattermost-server` | Go | From 6.6.0 | 6.6.1 |
| `github.com/mattermost/mattermost-server` | Go | From 6.6.0 | 6.6.1 |
| `mattermost` | Bitnami | From 5.0.0 to 6.5.0 | 6.3.8, 6.4.3 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2022-1982?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 6.3.8, 6.4.3, 6.5.1 or 6.6.1.

## Is CVE-2022-1982 being exploited?

There is no known exploitation of CVE-2022-1982 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1982 and fix it if it is affected.

What it is: CVE-2022-1982 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 2 Jun 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1982 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 5.0.0; fixed in 6.3.8
- github.com/mattermost/mattermost-server (Go): affected from 5.0.0; fixed in 6.3.8
- github.com/mattermost/mattermost-server (Go): affected from 6.4.0; fixed in 6.4.3
- github.com/mattermost/mattermost-server (Go): affected from 6.4.0; fixed in 6.4.3
- github.com/mattermost/mattermost-server (Go): affected from 6.5.0; fixed in 6.5.1
- github.com/mattermost/mattermost-server (Go): affected from 6.5.0; fixed in 6.5.1
- github.com/mattermost/mattermost-server (Go): affected from 6.6.0; fixed in 6.6.1
- github.com/mattermost/mattermost-server (Go): affected from 6.6.0; fixed in 6.6.1
- mattermost (Bitnami): affected from 5.0.0 up to 6.5.0; fixed in 6.3.8, 6.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1982/ (Markdown: https://insights.sbomify.com/CVE-2022-1982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1982
- OSV: https://osv.dev/vulnerability/CVE-2022-1982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1982/
Summaries are generated and may contain mistakes; the official description above is the record.
