# CVE-2022-1986: OS Command Injection in gogs/gogs

> Attackers can execute arbitrary OS commands on the server hosting Gogs, requiring an upgrade to the latest version.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-67mx-jc2f-jgjm, GO-2022-0556

## What is CVE-2022-1986?

CVE-2022-1986 is a critical command injection vulnerability in gogs/gogs, published on 9 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OS Command Injection in GitHub repository gogs/gogs prior to 0.12.9.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-1986?

3 open source packages ship an affected version, including gogs.io/gogs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gogs.io/gogs` | Go | All versions | 0.12.9 |
| `gogs.io/gogs` | Go | All versions | 0.12.9 |
| `gogs.io/gogs` | Go | All versions | 0.12.9 |

Products: Gogs Gogs.

## How do I fix CVE-2022-1986?

Upgrade gogs.io/gogs to 0.12.9 or later.

## Is CVE-2022-1986 being exploited?

There is no known exploitation of CVE-2022-1986 in the wild and no public exploit code.

## Other vulnerabilities in gogs/gogs

- [CVE-2025-8110](https://insights.sbomify.com/CVE-2025-8110/): Gogs Path Traversal (high 8.7, exploited in the wild)
- [CVE-2024-56731](https://insights.sbomify.com/CVE-2024-56731/): Gogs deletion of internal files allows remote command execution (critical 10.0)
- [CVE-2022-1884](https://insights.sbomify.com/CVE-2022-1884/): Remote Command Execution in gogs/gogs (critical 10.0)
- [CVE-2022-1992](https://insights.sbomify.com/CVE-2022-1992/): Path Traversal in gogs/gogs (critical 10.0)
- [CVE-2024-39930](https://insights.sbomify.com/CVE-2024-39930/): Duplicate Advisory: github.com/gogs/gogs affected by CVE-2024-39930 (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-1986 and fix it if it is affected.

What it is: CVE-2022-1986 is a critical command injection vulnerability in gogs/gogs, published on 9 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-1986 in the wild and no public exploit code.

Affected packages and fixed versions:
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.9
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.9
- gogs.io/gogs (Go): affected all versions; fixed in 0.12.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-1986/ (Markdown: https://insights.sbomify.com/CVE-2022-1986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-1986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-1986
- OSV: https://osv.dev/vulnerability/CVE-2022-1986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-1986/
Summaries are generated and may contain mistakes; the official description above is the record.
