CVE-2022-1999 Missing authorization in GitLab
An unprivileged user can modify label descriptions via the REST API due to missing authorization checks in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-1999?
CVE-2022-1999 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 1 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue has been discovered in GitLab CE/EE affecting all versions from 8.13 prior to 14.10.5, 15.0 prior to 15.0.4, and 15.1 prior to 15.1.1. Under certain conditions, using the REST API an unprivileged user was able to change labels description.
Which versions are affected by CVE-2022-1999?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 8.13.0 | 14.10.5, 15.0.4, 15.1.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-1999?
Upgrade gitlab to a fixed version for your release line: 14.10.5, 15.0.4 or 15.1.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-1999 being exploited?
There is no known exploitation of CVE-2022-1999 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-1999, GHSA-pvm7-rp3m-8gh2, UBUNTU-CVE-2022-1999.