{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-20001 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-20001 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-20001 and fix it if it is affected.\n\nWhat it is: CVE-2022-20001 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-20001 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-20001/ (Markdown: https://insights.sbomify.com/CVE-2022-20001/index.md)","id":"CVE-2022-20001","markdown":"https://insights.sbomify.com/CVE-2022-20001/index.md","name":"CVE-2022-20001","record":{"aliases":["ALPINE-CVE-2022-20001","DEBIAN-CVE-2022-20001","DSA-5234-1","GHSA-pj5f-6vxj-f5mq","MGASA-2022-0181","OESA-2022-1689","UBUNTU-CVE-2022-20001","USN-5367-1","openSUSE-SU-2022:0096-1","openSUSE-SU-2024:11936-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"fish shell","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into navigating to malicious directories, triggering unsafe git commands in the fish shell prompt.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"fish","vendor":"fishshell"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-427","name":"Uncontrolled Search Path Element"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"fish is a command line shell. fish version 3.1.0 through version 3.3.1 is vulnerable to arbitrary code execution. git repositories can contain per-repository configuration that change the behavior of git, including running arbitrary commands. When using the default configuration of fish, changing to a directory automatically runs `git` commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory into one controlled by the attacker, such as on a shared file system or extracted archive, fish will run arbitrary commands under the attacker's control. This problem has been fixed in fish 3.4.0. Note that running git in these directories, including using the git tab completion, remains a potential trigger for this issue. As a workaround, remove the `fish_git_prompt` function from the prompt.","ecosystems":["SUSE:Package Hub 15 SP3","openSUSE:Leap 15.3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Injection in fish","id":"CVE-2022-20001","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":7,"next":{"headline":"Missing authorization in Android","id":"CVE-2022-20002"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP3","fixed":["3.3.1-bp153.2.10.1"],"introduced":["0"],"last_affected":[],"package":"fish3","purl":"pkg:rpm/suse/fish3\u0026distro=SUSE%20Package%20Hub%2015%20SP3","source":"openSUSE-SU-2022:0096-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["3.3.1-bp153.2.10.1"],"introduced":["0"],"last_affected":[],"package":"fish3","purl":"pkg:rpm/opensuse/fish3\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2022:0096-1"}],"prev":{"headline":"JetFormBuilder Stripe Gateway \u003c 1.1.0 - Unauthenticated Blind SQLi via Payment Token","id":"CVE-2022-4997"},"products":["fish-shell"],"published":"2022-03-14","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["fish-shell"]},"summary":"Attackers can execute arbitrary code by tricking users into navigating to malicious directories, triggering unsafe git commands in the fish shell prompt.","url":"https://insights.sbomify.com/CVE-2022-20001/"}