# CVE-2022-20001: Injection in fish

> Attackers can execute arbitrary code by tricking users into navigating to malicious directories, triggering unsafe git commands in the fish shell prompt.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Mar 2022
- **Updated:** 23 Apr 2025
- **Also known as:** ALPINE-CVE-2022-20001, DEBIAN-CVE-2022-20001, DSA-5234-1, GHSA-pj5f-6vxj-f5mq, MGASA-2022-0181, OESA-2022-1689, UBUNTU-CVE-2022-20001, USN-5367-1, openSUSE-SU-2022:0096-1, openSUSE-SU-2024:11936-1

## What is CVE-2022-20001?

CVE-2022-20001 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

fish is a command line shell. fish version 3.1.0 through version 3.3.1 is vulnerable to arbitrary code execution. git repositories can contain per-repository configuration that change the behavior of git, including running arbitrary commands. When using the default configuration of fish, changing to a directory automatically runs `git` commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory into one controlled by the attacker, such as on a shared file system or extracted archive, fish will run arbitrary commands under the attacker's control. This problem has been fixed in fish 3.4.0. Note that running git in these directories, including using the git tab completion, remains a potential trigger for this issue. As a workaround, remove the `fish_git_prompt` function from the prompt.

Weakness: CWE-427 (Uncontrolled Search Path Element), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-20001?

It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fish3` | SUSE:Package Hub 15 SP3 | All versions | 3.3.1-bp153.2.10.1 |
| `fish3` | openSUSE:Leap 15.3 | All versions | 3.3.1-bp153.2.10.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Fishshell Fish.

## How do I fix CVE-2022-20001?

Upgrade to a fixed version.

## Is CVE-2022-20001 being exploited?

There is no known exploitation of CVE-2022-20001 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-20001 and fix it if it is affected.

What it is: CVE-2022-20001 is a high-severity command injection vulnerability in Debian Debian Linux, published on 14 Mar 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-20001 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-20001/ (Markdown: https://insights.sbomify.com/CVE-2022-20001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-20001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-20001
- OSV: https://osv.dev/vulnerability/CVE-2022-20001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-20001/
Summaries are generated and may contain mistakes; the official description above is the record.
