{"answers":{"affected":"3 open source packages ship an affected version, including nuitka and Nuitka. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2054 in the wild and no public exploit code.","fix":"Upgrade nuitka to 0.9 or later.","what":"CVE-2022-2054 is a high-severity code injection vulnerability in nuitka/nuitka, published on 12 Jun 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2054 and fix it if it is affected.\n\nWhat it is: CVE-2022-2054 is a high-severity code injection vulnerability in nuitka/nuitka, published on 12 Jun 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-2054 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nuitka (PyPI): affected all versions; fixed in 0.9\n- nuitka (PyPI): affected all versions; fixed in 0.9\n- Nuitka (PyPI): affected all versions; fixed in 0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2054/ (Markdown: https://insights.sbomify.com/CVE-2022-2054/index.md)","id":"CVE-2022-2054","markdown":"https://insights.sbomify.com/CVE-2022-2054/index.md","name":"CVE-2022-2054","record":{"aliases":["DEBIAN-CVE-2022-2054","GHSA-4v3r-hqr9-69jf","PYSEC-2022-209","UBUNTU-CVE-2022-2054"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python compiler","requires_auth":"none","summary":"Attackers can execute arbitrary code via code injection in the Nuitka Python compiler, requiring an upgrade to a patched version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"nuitka","vendor":"nuitka"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Code Injection in GitHub repository nuitka/nuitka prior to 0.9.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code Injection in nuitka/nuitka","id":"CVE-2022-2054","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Denial of service in libtiff","id":"CVE-2022-2056"},"packages":[{"ecosystem":"PyPI","fixed":["0.9"],"introduced":["0"],"last_affected":[],"package":"Nuitka","purl":null,"source":"GHSA-4v3r-hqr9-69jf"},{"ecosystem":"PyPI","fixed":["0.9"],"introduced":["0"],"last_affected":[],"package":"nuitka","purl":"pkg:pypi/nuitka","source":"GHSA-4v3r-hqr9-69jf"},{"ecosystem":"PyPI","fixed":["0.9"],"introduced":["0"],"last_affected":[],"package":"nuitka","purl":"pkg:pypi/nuitka","source":"PYSEC-2022-209"}],"prev":{"headline":"Undertow vulnerable to Dos via Large AJP request","id":"CVE-2022-2053"},"products":["nuitka/nuitka"],"published":"2022-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["nuitka"]},"summary":"Attackers can execute arbitrary code via code injection in the Nuitka Python compiler, requiring an upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2022-2054/"}