{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2061 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-2061 is a low-severity memory corruption vulnerability in hpjansson/chafa, published on 13 Jun 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-2061 and fix it if it is affected.\n\nWhat it is: CVE-2022-2061 is a low-severity memory corruption vulnerability in hpjansson/chafa, published on 13 Jun 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-2061 in the wild and no public exploit code.\n\nAffected product: hpjansson/chafa. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2061/ (Markdown: https://insights.sbomify.com/CVE-2022-2061/index.md)","id":"CVE-2022-2061","markdown":"https://insights.sbomify.com/CVE-2022-2061/index.md","name":"CVE-2022-2061","record":{"aliases":["DEBIAN-CVE-2022-2061","GHSA-q3m2-24xm-qm8c","JLSEC-2026-1090","UBUNTU-CVE-2022-2061","openSUSE-SU-2022:10017-1","openSUSE-SU-2024:12151-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Image conversion library","requires_auth":"low_privilege","summary":"A heap-based buffer overflow in Chafa allows attackers to execute arbitrary code or cause denial of service via crafted images.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"chafa","vendor":"chafa_project"}],"cvss":{"score":2.8,"severity":"low","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Heap-based Buffer Overflow in GitHub repository hpjansson/chafa prior to 1.12.0.","ecosystems":["SUSE:Package Hub 15 SP4","openSUSE:Leap 15.4","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Heap-based Buffer Overflow in hpjansson/chafa","id":"CVE-2022-2061","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Generation of Error Message Containing Sensitive Information in nocodb/nocodb","id":"CVE-2022-2062"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["1.8.0-bp154.3.3.1"],"introduced":["0"],"last_affected":[],"package":"chafa","purl":"pkg:rpm/suse/chafa\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2022:10017-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["1.8.0-bp154.3.3.1"],"introduced":["0"],"last_affected":[],"package":"chafa","purl":"pkg:rpm/opensuse/chafa\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2022:10017-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.12.1-1.1"],"introduced":["0"],"last_affected":[],"package":"chafa","purl":"pkg:rpm/opensuse/chafa\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12151-1"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in dolibarr/dolibarr","id":"CVE-2022-2060"},"products":["hpjansson/chafa"],"published":"2022-06-13","related":[{"cvss_score":5.5,"headline":"Buffer Over-read in hpjansson/chafa","id":"CVE-2022-2301","kev_date_added":null,"published":"2022-07-04"},{"cvss_score":5.5,"headline":"Null dereference in hpjansson/chafa","id":"CVE-2022-1507","kev_date_added":null,"published":"2022-04-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["hpjansson"]},"summary":"A heap-based buffer overflow in Chafa allows attackers to execute arbitrary code or cause denial of service via crafted images.","url":"https://insights.sbomify.com/CVE-2022-2061/"}