CVE-2022-20615 Stored XSS vulnerability in Matrix Project Plugin

Medium 5.4 Published Updated

Stored XSS in Jenkins Matrix Project Plugin allows attackers with Agent/Configure permission to execute scripts via node or label names.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-20615?

CVE-2022-20615 is a medium-severity cross-site scripting vulnerability in Oracle Communications Cloud Native Core Automated Test Suite, published on 12 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Jenkins Matrix Project Plugin 1.19 and earlier does not escape HTML metacharacters in node and label names, and label descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission.

Weakness: CWE-79

Which versions are affected by CVE-2022-20615?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:matrix-project. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.plugins:matrix-project MavenAll versions1.18.1
org.jenkins-ci.plugins:matrix-project MavenAll versions1.18.1
org.jenkins-ci.plugins:matrix-project MavenFrom 1.191.20
org.jenkins-ci.plugins:matrix-project MavenFrom 1.191.20

Products include Jenkins Matrix Project, Oracle Communications Cloud Native Core Automated Test Suite.

How do I fix CVE-2022-20615?

Upgrade org.jenkins-ci.plugins:matrix-project to a fixed version for your release line: 1.18.1 or 1.20.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-20615 being exploited?

There is no known exploitation of CVE-2022-20615 in the wild and no public exploit code.

All Oracle Communications Cloud Native Core Automated Test Suite vulnerabilities

Sources

Also known as GHSA-vqwg-4v6f-h6x5.

Is CVE-2022-20615 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free