# CVE-2022-20615: Stored XSS vulnerability in Matrix Project Plugin

> Stored XSS in Jenkins Matrix Project Plugin allows attackers with Agent/Configure permission to execute scripts via node or label names.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vqwg-4v6f-h6x5

## What is CVE-2022-20615?

CVE-2022-20615 is a medium-severity cross-site scripting vulnerability in Oracle Communications Cloud Native Core Automated Test Suite, published on 12 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Matrix Project Plugin 1.19 and earlier does not escape HTML metacharacters in node and label names, and label descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-20615?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:matrix-project. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:matrix-project` | Maven | All versions | 1.18.1 |
| `org.jenkins-ci.plugins:matrix-project` | Maven | All versions | 1.18.1 |
| `org.jenkins-ci.plugins:matrix-project` | Maven | From 1.19 | 1.20 |
| `org.jenkins-ci.plugins:matrix-project` | Maven | From 1.19 | 1.20 |

Products: Jenkins Matrix Project, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2022-20615?

Upgrade org.jenkins-ci.plugins:matrix-project to a fixed version for your release line: 1.18.1 or 1.20.

## Is CVE-2022-20615 being exploited?

There is no known exploitation of CVE-2022-20615 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Communications Cloud Native Core Automated Test Suite

- [CVE-2019-1003031](https://insights.sbomify.com/CVE-2019-1003031/): Script security sandbox bypass in Matrix Project Plugin (critical 9.9)
- [CVE-2020-2224](https://insights.sbomify.com/CVE-2020-2224/): Stored XSS vulnerability in single axis builds tooltips in Jenkins Matrix Project Plugin (medium 5.4)
- [CVE-2020-2225](https://insights.sbomify.com/CVE-2020-2225/): Stored XSS vulnerability in multiple axis builds tooltips in Jenkins Matrix Project Plugin (medium 5.4)
- [CVE-2024-23900](https://insights.sbomify.com/CVE-2024-23900/): Path traversal vulnerability in Jenkins Matrix Project Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-20615 and fix it if it is affected.

What it is: CVE-2022-20615 is a medium-severity cross-site scripting vulnerability in Oracle Communications Cloud Native Core Automated Test Suite, published on 12 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-20615 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:matrix-project (Maven): affected all versions; fixed in 1.18.1
- org.jenkins-ci.plugins:matrix-project (Maven): affected all versions; fixed in 1.18.1
- org.jenkins-ci.plugins:matrix-project (Maven): affected from 1.19; fixed in 1.20
- org.jenkins-ci.plugins:matrix-project (Maven): affected from 1.19; fixed in 1.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-20615/ (Markdown: https://insights.sbomify.com/CVE-2022-20615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-20615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-20615
- OSV: https://osv.dev/vulnerability/CVE-2022-20615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-20615/
Summaries are generated and may contain mistakes; the official description above is the record.
