# CVE-2022-20616: Incorrect Permission Assignment for Critical Resource in Jenkins Credentials Binding Plugin

> Attackers with read access can validate credential IDs and file types due to missing permission checks in form validation.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gqm2-2gcx-p88w

## What is CVE-2022-20616?

CVE-2022-20616 is a medium-severity missing authorization vulnerability in Jenkins Credentials Binding Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Credentials Binding Plugin 1.27 and earlier does not perform a permission check in a method implementing form validation, allowing attackers with Overall/Read access to validate if a credential ID refers to a secret file credential and whether it's a zip file.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-20616?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:credentials-binding. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:credentials-binding` | Maven | All versions | 1.24.1 |
| `org.jenkins-ci.plugins:credentials-binding` | Maven | All versions | 1.24.1 |
| `org.jenkins-ci.plugins:credentials-binding` | Maven | From 1.25 | 1.27.1 |
| `org.jenkins-ci.plugins:credentials-binding` | Maven | From 1.25 | 1.27.1 |

Products: Jenkins Credentials Binding.

## How do I fix CVE-2022-20616?

Upgrade org.jenkins-ci.plugins:credentials-binding to a fixed version for your release line: 1.24.1 or 1.27.1.

## Is CVE-2022-20616 being exploited?

There is no known exploitation of CVE-2022-20616 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Credentials Binding Plugin

- [CVE-2026-48922](https://insights.sbomify.com/CVE-2026-48922/): Jenkins Credentials Binding Plugin does not properly sanitize file names for file and zip file credentials (high 7.5)
- [CVE-2026-42520](https://insights.sbomify.com/CVE-2026-42520/): Jenkins Credentials Binding Plugin has a path traversal vulnerability (high 7.5)
- [CVE-2025-53650](https://insights.sbomify.com/CVE-2025-53650/): Jenkins Credentials Binding Plugin vulnerability can expose sensitive information in logger messages (high 7.3)
- [CVE-2020-2181](https://insights.sbomify.com/CVE-2020-2181/): Secrets are not masked by Jenkins Credentials Binding Plugin in builds without build steps (medium 6.5)
- [CVE-2019-1010241](https://insights.sbomify.com/CVE-2019-1010241/): Jenkins Credentials Binding Plugin Stores Passwords in a Recoverable Format (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-20616 and fix it if it is affected.

What it is: CVE-2022-20616 is a medium-severity missing authorization vulnerability in Jenkins Credentials Binding Plugin, published on 12 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-20616 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:credentials-binding (Maven): affected all versions; fixed in 1.24.1
- org.jenkins-ci.plugins:credentials-binding (Maven): affected all versions; fixed in 1.24.1
- org.jenkins-ci.plugins:credentials-binding (Maven): affected from 1.25; fixed in 1.27.1
- org.jenkins-ci.plugins:credentials-binding (Maven): affected from 1.25; fixed in 1.27.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-20616/ (Markdown: https://insights.sbomify.com/CVE-2022-20616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-20616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-20616
- OSV: https://osv.dev/vulnerability/CVE-2022-20616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-20616/
Summaries are generated and may contain mistakes; the official description above is the record.
