# CVE-2022-20621: Access key stored in plain text by Jenkins Metrics Plugin

> Attackers with file system access can read unencrypted access keys from the Jenkins Metrics Plugin configuration file.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gg9m-x3cg-69vh

## What is CVE-2022-20621?

CVE-2022-20621 is a medium-severity vulnerability in Jenkins Metrics Plugin, published on 12 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jenkins Metrics Plugin 4.0.2.8 and earlier stores an access key unencrypted in its global configuration file on the Jenkins controller where it can be viewed by users with access to the Jenkins controller file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2022-20621?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:metrics. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:metrics` | Maven | All versions | 4.0.2.7.1 |
| `org.jenkins-ci.plugins:metrics` | Maven | All versions | 4.0.2.7.1 |
| `org.jenkins-ci.plugins:metrics` | Maven | From 4.0.2.8 | 4.0.2.8.1 |
| `org.jenkins-ci.plugins:metrics` | Maven | From 4.0.2.8 | 4.0.2.8.1 |

Products: Jenkins Metrics.

## How do I fix CVE-2022-20621?

Upgrade org.jenkins-ci.plugins:metrics to a fixed version for your release line: 4.0.2.7.1 or 4.0.2.8.1.

## Is CVE-2022-20621 being exploited?

There is no known exploitation of CVE-2022-20621 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-20621 and fix it if it is affected.

What it is: CVE-2022-20621 is a medium-severity vulnerability in Jenkins Metrics Plugin, published on 12 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-20621 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:metrics (Maven): affected all versions; fixed in 4.0.2.7.1
- org.jenkins-ci.plugins:metrics (Maven): affected all versions; fixed in 4.0.2.7.1
- org.jenkins-ci.plugins:metrics (Maven): affected from 4.0.2.8; fixed in 4.0.2.8.1
- org.jenkins-ci.plugins:metrics (Maven): affected from 4.0.2.8; fixed in 4.0.2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-20621/ (Markdown: https://insights.sbomify.com/CVE-2022-20621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-20621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-20621
- OSV: https://osv.dev/vulnerability/CVE-2022-20621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-20621/
Summaries are generated and may contain mistakes; the official description above is the record.
