{"answers":{"affected":"2 open source packages ship an affected version, including nocodb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2063 in the wild and no public exploit code.","fix":"Upgrade nocodb to 0.91.8 or later.","what":"CVE-2022-2063 is a critical vulnerability in nocodb/nocodb, published on 13 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-2063 and fix it if it is affected.\n\nWhat it is: CVE-2022-2063 is a critical vulnerability in nocodb/nocodb, published on 13 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-2063 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nocodb (npm): affected all versions; fixed in 0.91.8\n- nocodb (npm): affected all versions; fixed in 0.91.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2063/ (Markdown: https://insights.sbomify.com/CVE-2022-2063/index.md)","id":"CVE-2022-2063","markdown":"https://insights.sbomify.com/CVE-2022-2063/index.md","name":"CVE-2022-2063","record":{"aliases":["GHSA-fq4h-m3c8-8m2v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"NocoDB application","requires_auth":"low_privilege","summary":"Attackers can exploit improper privilege management in NocoDB to escalate privileges within the application.","user_interaction":"required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"nocodb","vendor":"nocodb"}],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Improper Privilege Management in GitHub repository nocodb/nocodb prior to 0.91.7+.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Privilege Management in nocodb/nocodb","id":"CVE-2022-2063","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Insufficient Session Expiration in nocodb/nocodb","id":"CVE-2022-2064"},"packages":[{"ecosystem":"npm","fixed":["0.91.8"],"introduced":["0"],"last_affected":[],"package":"nocodb","purl":null,"source":"GHSA-fq4h-m3c8-8m2v"},{"ecosystem":"npm","fixed":["0.91.8"],"introduced":["0"],"last_affected":[],"package":"nocodb","purl":"pkg:npm/nocodb","source":"GHSA-fq4h-m3c8-8m2v"}],"prev":{"headline":"Generation of Error Message Containing Sensitive Information in nocodb/nocodb","id":"CVE-2022-2062"},"products":["nocodb/nocodb"],"published":"2022-06-13","related":[{"cvss_score":9.1,"headline":"Server-Side Request Forgery (SSRF) in nocodb/nocodb","id":"CVE-2022-2339","kev_date_added":null,"published":"2022-07-07"},{"cvss_score":9.1,"headline":"Generation of Error Message Containing Sensitive Information in nocodb/nocodb","id":"CVE-2022-2062","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9.1,"headline":"Insufficient Session Expiration in nocodb/nocodb","id":"CVE-2022-2064","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9,"headline":"Cross-site Scripting (XSS) - Stored in nocodb/nocodb","id":"CVE-2022-2022","kev_date_added":null,"published":"2022-06-07"},{"cvss_score":8.5,"headline":"NocoDB Vulnerable to Stored Cross-Site Scripting via SVG upload","id":"CVE-2026-24769","kev_date_added":null,"published":"2026-01-28"},{"cvss_score":8,"headline":"NocoDB - CSV Injection in User Management","id":"CVE-2022-22121","kev_date_added":null,"published":"2022-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["nocodb"]},"summary":"Attackers can exploit improper privilege management in NocoDB to escalate privileges within the application.","url":"https://insights.sbomify.com/CVE-2022-2063/"}