{"answers":{"affected":"2 open source packages ship an affected version, including nocodb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2064 in the wild and no public exploit code.","fix":"Upgrade nocodb to 0.91.9 or later.","what":"CVE-2022-2064 is a critical vulnerability in nocodb/nocodb, published on 13 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-2064 and fix it if it is affected.\n\nWhat it is: CVE-2022-2064 is a critical vulnerability in nocodb/nocodb, published on 13 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-2064 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nocodb (npm): affected all versions; fixed in 0.91.9\n- nocodb (npm): affected all versions; fixed in 0.91.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2064/ (Markdown: https://insights.sbomify.com/CVE-2022-2064/index.md)","id":"CVE-2022-2064","markdown":"https://insights.sbomify.com/CVE-2022-2064/index.md","name":"CVE-2022-2064","record":{"aliases":["GHSA-6293-2vg2-pmp5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"NocoDB web application","requires_auth":"high_privilege","summary":"Attackers can maintain unauthorized access due to insufficient session expiration in NocoDB, requiring an upgrade to secure user accounts.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"nocodb","vendor":"nocodb"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"Insufficient Session Expiration in GitHub repository nocodb/nocodb prior to 0.91.7+.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficient Session Expiration in nocodb/nocodb","id":"CVE-2022-2064","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) - Stored in neorazorx/facturascripts","id":"CVE-2022-2065"},"packages":[{"ecosystem":"npm","fixed":["0.91.9"],"introduced":["0"],"last_affected":[],"package":"nocodb","purl":null,"source":"GHSA-6293-2vg2-pmp5"},{"ecosystem":"npm","fixed":["0.91.9"],"introduced":["0"],"last_affected":[],"package":"nocodb","purl":"pkg:npm/nocodb","source":"GHSA-6293-2vg2-pmp5"}],"prev":{"headline":"Improper Privilege Management in nocodb/nocodb","id":"CVE-2022-2063"},"products":["nocodb/nocodb"],"published":"2022-06-13","related":[{"cvss_score":9.1,"headline":"Server-Side Request Forgery (SSRF) in nocodb/nocodb","id":"CVE-2022-2339","kev_date_added":null,"published":"2022-07-07"},{"cvss_score":9.1,"headline":"Generation of Error Message Containing Sensitive Information in nocodb/nocodb","id":"CVE-2022-2062","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9,"headline":"Improper Privilege Management in nocodb/nocodb","id":"CVE-2022-2063","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9,"headline":"Cross-site Scripting (XSS) - Stored in nocodb/nocodb","id":"CVE-2022-2022","kev_date_added":null,"published":"2022-06-07"},{"cvss_score":8.5,"headline":"NocoDB Vulnerable to Stored Cross-Site Scripting via SVG upload","id":"CVE-2026-24769","kev_date_added":null,"published":"2026-01-28"},{"cvss_score":8,"headline":"NocoDB - CSV Injection in User Management","id":"CVE-2022-22121","kev_date_added":null,"published":"2022-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["nocodb"]},"summary":"Attackers can maintain unauthorized access due to insufficient session expiration in NocoDB, requiring an upgrade to secure user accounts.","url":"https://insights.sbomify.com/CVE-2022-2064/"}