# CVE-2022-2064: Insufficient Session Expiration in nocodb/nocodb

> Attackers can maintain unauthorized access due to insufficient session expiration in NocoDB, requiring an upgrade to secure user accounts.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6293-2vg2-pmp5

## What is CVE-2022-2064?

CVE-2022-2064 is a critical vulnerability in nocodb/nocodb, published on 13 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Insufficient Session Expiration in GitHub repository nocodb/nocodb prior to 0.91.7+.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-2064?

2 open source packages ship an affected version, including nocodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 0.91.9 |
| `nocodb` | npm | All versions | 0.91.9 |

Products: Nocodb Nocodb.

## How do I fix CVE-2022-2064?

Upgrade nocodb to 0.91.9 or later.

## Is CVE-2022-2064 being exploited?

There is no known exploitation of CVE-2022-2064 in the wild and no public exploit code.

## Other vulnerabilities in nocodb/nocodb

- [CVE-2022-2339](https://insights.sbomify.com/CVE-2022-2339/): Server-Side Request Forgery (SSRF) in nocodb/nocodb (critical 9.1)
- [CVE-2022-2062](https://insights.sbomify.com/CVE-2022-2062/): Generation of Error Message Containing Sensitive Information in nocodb/nocodb (critical 9.1)
- [CVE-2022-2063](https://insights.sbomify.com/CVE-2022-2063/): Improper Privilege Management in nocodb/nocodb (critical 9.0)
- [CVE-2022-2022](https://insights.sbomify.com/CVE-2022-2022/): Cross-site Scripting (XSS) - Stored in nocodb/nocodb (critical 9.0)
- [CVE-2026-24769](https://insights.sbomify.com/CVE-2026-24769/): NocoDB Vulnerable to Stored Cross-Site Scripting via SVG upload (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2064 and fix it if it is affected.

What it is: CVE-2022-2064 is a critical vulnerability in nocodb/nocodb, published on 13 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2064 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 0.91.9
- nocodb (npm): affected all versions; fixed in 0.91.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2064/ (Markdown: https://insights.sbomify.com/CVE-2022-2064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2064
- OSV: https://osv.dev/vulnerability/CVE-2022-2064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2064/
Summaries are generated and may contain mistakes; the official description above is the record.
