# CVE-2022-2073: Code Injection in getgrav/grav

> Attackers can execute arbitrary code in Grav CMS, requiring an upgrade to the latest version for mitigation.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jun 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-cxgw-r5jg-7xwq

## What is CVE-2022-2073?

CVE-2022-2073 is a critical code injection vulnerability in Getgrav Grav, published on 29 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Code Injection in GitHub repository getgrav/grav prior to 1.7.34.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-2073?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.34 |
| `getgrav/grav` | Packagist | All versions | 1.7.34 |

Products: Getgrav Grav.

## How do I fix CVE-2022-2073?

Upgrade getgrav/grav to 1.7.34 or later.

## Is CVE-2022-2073 being exploited?

There is no known exploitation of CVE-2022-2073 in the wild and no public exploit code.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2026-42611](https://insights.sbomify.com/CVE-2026-42611/): Grav: Stored XSS via Tag Injection (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2073 and fix it if it is affected.

What it is: CVE-2022-2073 is a critical code injection vulnerability in Getgrav Grav, published on 29 Jun 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-2073 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.34
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2073/ (Markdown: https://insights.sbomify.com/CVE-2022-2073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2073
- OSV: https://osv.dev/vulnerability/CVE-2022-2073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2073/
Summaries are generated and may contain mistakes; the official description above is the record.
