{"answers":{"affected":"2 open source packages ship an affected version, including nocodb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2079 in the wild and no public exploit code.","fix":"Upgrade nocodb to 0.91.9 or later.","what":"CVE-2022-2079 is a high-severity cross-site scripting vulnerability in nocodb/nocodb, published on 14 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-2079 and fix it if it is affected.\n\nWhat it is: CVE-2022-2079 is a high-severity cross-site scripting vulnerability in nocodb/nocodb, published on 14 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-2079 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nocodb (npm): affected all versions; fixed in 0.91.9\n- nocodb (npm): affected all versions; fixed in 0.91.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2079/ (Markdown: https://insights.sbomify.com/CVE-2022-2079/index.md)","id":"CVE-2022-2079","markdown":"https://insights.sbomify.com/CVE-2022-2079/index.md","name":"CVE-2022-2079","record":{"aliases":["GHSA-hv6q-5g4f-8897"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"NocoDB web application","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into NocoDB, potentially executing code or hijacking user accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"nocodb","vendor":"nocodb"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) - Stored in GitHub repository nocodb/nocodb prior to 0.91.7+.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Stored in nocodb/nocodb","id":"CVE-2022-2079","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Sensei LMS \u003c 4.5.2 - Arbitrary Private Message Sending via IDOR","id":"CVE-2022-2080"},"packages":[{"ecosystem":"npm","fixed":["0.91.9"],"introduced":["0"],"last_affected":[],"package":"nocodb","purl":null,"source":"GHSA-hv6q-5g4f-8897"},{"ecosystem":"npm","fixed":["0.91.9"],"introduced":["0"],"last_affected":[],"package":"nocodb","purl":"pkg:npm/nocodb","source":"GHSA-hv6q-5g4f-8897"}],"prev":{"headline":"Memory corruption in kernel","id":"CVE-2022-2078"},"products":["nocodb/nocodb"],"published":"2022-06-14","related":[{"cvss_score":9.1,"headline":"Server-Side Request Forgery (SSRF) in nocodb/nocodb","id":"CVE-2022-2339","kev_date_added":null,"published":"2022-07-07"},{"cvss_score":9.1,"headline":"Generation of Error Message Containing Sensitive Information in nocodb/nocodb","id":"CVE-2022-2062","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9.1,"headline":"Insufficient Session Expiration in nocodb/nocodb","id":"CVE-2022-2064","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9,"headline":"Improper Privilege Management in nocodb/nocodb","id":"CVE-2022-2063","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9,"headline":"Cross-site Scripting (XSS) - Stored in nocodb/nocodb","id":"CVE-2022-2022","kev_date_added":null,"published":"2022-06-07"},{"cvss_score":8.5,"headline":"NocoDB Vulnerable to Stored Cross-Site Scripting via SVG upload","id":"CVE-2026-24769","kev_date_added":null,"published":"2026-01-28"},{"cvss_score":8,"headline":"NocoDB - CSV Injection in User Management","id":"CVE-2022-22121","kev_date_added":null,"published":"2022-01-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["nocodb"]},"summary":"Attackers can inject malicious scripts into NocoDB, potentially executing code or hijacking user accounts.","url":"https://insights.sbomify.com/CVE-2022-2079/"}