{"answers":{"affected":"2 open source packages ship an affected version, including woocommerce/woocommerce. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-2099 in the wild and no public exploit code.","fix":"Upgrade woocommerce/woocommerce to 6.6.0 or later.","what":"CVE-2022-2099 is a medium-severity cross-site scripting vulnerability in Unknown WooCommerce, published on 17 Jul 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-2099 and fix it if it is affected.\n\nWhat it is: CVE-2022-2099 is a medium-severity cross-site scripting vulnerability in Unknown WooCommerce, published on 17 Jul 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-2099 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- woocommerce/woocommerce (Packagist): affected all versions; fixed in 6.6.0\n- woocommerce/woocommerce (Packagist): affected all versions; fixed in 6.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-2099/ (Markdown: https://insights.sbomify.com/CVE-2022-2099/index.md)","id":"CVE-2022-2099","markdown":"https://insights.sbomify.com/CVE-2022-2099/index.md","name":"CVE-2022-2099","record":{"aliases":["GHSA-jwvf-28fg-g4xg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WooCommerce plugin","requires_auth":"high_privilege","summary":"Admins can inject stored HTML into payment gateway titles, potentially leading to script execution and account takeover in WooCommerce installations.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"WPScan","cpe":[{"product":"woocommerce","vendor":"woocommerce"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"The WooCommerce WordPress plugin before 6.6.0 is vulnerable to stored HTML injection due to lack of escaping and sanitizing in the payment gateway titles","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WooCommerce \u003c 6.6.0 - Admin+ Stored HTML Injection","id":"CVE-2022-2099","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Page Generator Plugin \u003c 1.6.5 - Admin+ Stored Cross-Site Scripting","id":"CVE-2022-2100"},"packages":[{"ecosystem":"Packagist","fixed":["6.6.0"],"introduced":["0"],"last_affected":[],"package":"woocommerce/woocommerce","purl":null,"source":"GHSA-jwvf-28fg-g4xg"},{"ecosystem":"Packagist","fixed":["6.6.0"],"introduced":["0"],"last_affected":[],"package":"woocommerce/woocommerce","purl":"pkg:composer/woocommerce/woocommerce","source":"GHSA-jwvf-28fg-g4xg"}],"prev":{"headline":"Weak Password Requirements in kromitgmbh/titra","id":"CVE-2022-2098"},"products":["WooCommerce"],"published":"2022-07-17","related":[{"cvss_score":8.8,"headline":"WooCommerce Cross-Site Request Forgery (CSRF)","id":"CVE-2019-20891","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2017-18356","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":8.1,"headline":"Path traversal in n/a","id":"CVE-2018-20714","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":6.1,"headline":"WooCommerce \u003c= 9.4.2 - PostMessage-Based Cross-Site Scripting","id":"CVE-2025-5062","kev_date_added":null,"published":"2025-05-22"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2019-9168","kev_date_added":null,"published":"2019-02-26"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2015-2329","kev_date_added":null,"published":"2018-02-08"},{"cvss_score":5.9,"headline":"WordPress Product page shipping calculator for WooCommerce Plugin \u003c= 1.3.25 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-32575","kev_date_added":null,"published":"2023-08-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Unknown"]},"summary":"Admins can inject stored HTML into payment gateway titles, potentially leading to script execution and account takeover in WooCommerce installations.","url":"https://insights.sbomify.com/CVE-2022-2099/"}