# CVE-2022-2099: WooCommerce < 6.6.0 - Admin+ Stored HTML Injection

> Admins can inject stored HTML into payment gateway titles, potentially leading to script execution and account takeover in WooCommerce installations.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-jwvf-28fg-g4xg

## What is CVE-2022-2099?

CVE-2022-2099 is a medium-severity cross-site scripting vulnerability in Unknown WooCommerce, published on 17 Jul 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The WooCommerce WordPress plugin before 6.6.0 is vulnerable to stored HTML injection due to lack of escaping and sanitizing in the payment gateway titles

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2022-2099?

2 open source packages ship an affected version, including woocommerce/woocommerce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `woocommerce/woocommerce` | Packagist | All versions | 6.6.0 |
| `woocommerce/woocommerce` | Packagist | All versions | 6.6.0 |

Products: Woocommerce Woocommerce.

## How do I fix CVE-2022-2099?

Upgrade woocommerce/woocommerce to 6.6.0 or later.

## Is CVE-2022-2099 being exploited?

There is no known exploitation of CVE-2022-2099 in the wild and no public exploit code.

## Other vulnerabilities in Unknown WooCommerce

- [CVE-2019-20891](https://insights.sbomify.com/CVE-2019-20891/): WooCommerce Cross-Site Request Forgery (CSRF) (high 8.8)
- [CVE-2017-18356](https://insights.sbomify.com/CVE-2017-18356/): Code injection in n/a (high 8.8)
- [CVE-2018-20714](https://insights.sbomify.com/CVE-2018-20714/): Path traversal in n/a (high 8.1)
- [CVE-2025-5062](https://insights.sbomify.com/CVE-2025-5062/): WooCommerce <= 9.4.2 - PostMessage-Based Cross-Site Scripting (medium 6.1)
- [CVE-2019-9168](https://insights.sbomify.com/CVE-2019-9168/): Cross-site scripting in n/a (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2099 and fix it if it is affected.

What it is: CVE-2022-2099 is a medium-severity cross-site scripting vulnerability in Unknown WooCommerce, published on 17 Jul 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-2099 in the wild and no public exploit code.

Affected packages and fixed versions:
- woocommerce/woocommerce (Packagist): affected all versions; fixed in 6.6.0
- woocommerce/woocommerce (Packagist): affected all versions; fixed in 6.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2099/ (Markdown: https://insights.sbomify.com/CVE-2022-2099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2099
- OSV: https://osv.dev/vulnerability/CVE-2022-2099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2099/
Summaries are generated and may contain mistakes; the official description above is the record.
