# CVE-2022-21122: Arbitrary Code Execution

> Attackers can execute arbitrary code by accessing the Function constructor via the exposed Math class in the metacalc library.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5gc4-cx9x-9c43, SNYK-JS-METACALC-2826197

## What is CVE-2022-21122?

CVE-2022-21122 is a critical code injection vulnerability in metacalc, published on 3 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package metacalc before 0.0.2 are vulnerable to Arbitrary Code Execution when it exposes JavaScript's Math class to the v8 context. As the Math class is exposed to user-land, it can be used to get access to JavaScript's Function constructor.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-21122?

2 open source packages ship an affected version, including metacalc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `metacalc` | npm | All versions | 0.0.2 |
| `metacalc` | npm | All versions | 0.0.2 |

Products: Metarhia Metacalc.

## How do I fix CVE-2022-21122?

Upgrade metacalc to 0.0.2 or later.

## Is CVE-2022-21122 being exploited?

There is no known exploitation of CVE-2022-21122 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21122 and fix it if it is affected.

What it is: CVE-2022-21122 is a critical code injection vulnerability in metacalc, published on 3 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21122 in the wild and no public exploit code.

Affected packages and fixed versions:
- metacalc (npm): affected all versions; fixed in 0.0.2
- metacalc (npm): affected all versions; fixed in 0.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21122/ (Markdown: https://insights.sbomify.com/CVE-2022-21122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21122
- OSV: https://osv.dev/vulnerability/CVE-2022-21122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21122/
Summaries are generated and may contain mistakes; the official description above is the record.
