# CVE-2022-21126: Creation of Temporary File in Directory with Insecure Permissions

> Attackers can exploit insecure temporary file creation to read or modify data, affecting users of the htsjdk Java library.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2022
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-96vh-4rfp-c42c, UBUNTU-CVE-2022-21126

## What is CVE-2022-21126?

CVE-2022-21126 is a high-severity vulnerability in com.github.samtools:htsjdk, published on 29 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package com.github.samtools:htsjdk before 3.0.1 are vulnerable to Creation of Temporary File in Directory with Insecure Permissions due to the createTempDir() function in util/IOUtil.java not checking for the existence of the temporary directory before attempting to create it.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2022-21126?

2 open source packages ship an affected version, including com.github.samtools:htsjdk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.github.samtools:htsjdk` | Maven | All versions | 3.0.1 |
| `com.github.samtools:htsjdk` | Maven | All versions | 3.0.1 |

Products: Samtools Htsjdk.

## How do I fix CVE-2022-21126?

Upgrade com.github.samtools:htsjdk to 3.0.1 or later.

## Is CVE-2022-21126 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21126 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21126 and fix it if it is affected.

What it is: CVE-2022-21126 is a high-severity vulnerability in com.github.samtools:htsjdk, published on 29 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21126 exists.

Affected packages and fixed versions:
- com.github.samtools:htsjdk (Maven): affected all versions; fixed in 3.0.1
- com.github.samtools:htsjdk (Maven): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21126/ (Markdown: https://insights.sbomify.com/CVE-2022-21126/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21126
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21126
- OSV: https://osv.dev/vulnerability/CVE-2022-21126

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21126/
Summaries are generated and may contain mistakes; the official description above is the record.
