CVE-2022-21129 nemo-appium vulnerable to OS Command Injection

High 7.4 Published Updated

Attackers can execute arbitrary commands via improper input sanitization in nemo-appium, requiring a specific dependency installation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-21129?

CVE-2022-21129 is a high-severity command injection vulnerability in nemo-appium, published on 31 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function. **Note:** In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.

Weakness: CWE-77, CWE-78

Which versions are affected by CVE-2022-21129?

2 open source packages ship an affected version, including nemo-appium. It affects 1 product.

PackageAffectedFixed in
nemo-appium npmAll versions0.0.9
nemo-appium npmAll versions0.0.9

Products include Paypal Nemo-Appium.

How do I fix CVE-2022-21129?

Upgrade nemo-appium to 0.0.9 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2022-21129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21129 exists.

Sources

Also known as GHSA-c6rx-gxqv-vr5j.

Is CVE-2022-21129 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free