{"answers":{"affected":"2 open source packages ship an affected version, including nemo-appium. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21129 exists.","fix":"Upgrade nemo-appium to 0.0.9 or later.","what":"CVE-2022-21129 is a high-severity command injection vulnerability in nemo-appium, published on 31 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21129 and fix it if it is affected.\n\nWhat it is: CVE-2022-21129 is a high-severity command injection vulnerability in nemo-appium, published on 31 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21129 exists.\n\nAffected packages and fixed versions:\n- nemo-appium (npm): affected all versions; fixed in 0.0.9\n- nemo-appium (npm): affected all versions; fixed in 0.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21129/ (Markdown: https://insights.sbomify.com/CVE-2022-21129/index.md)","id":"CVE-2022-21129","markdown":"https://insights.sbomify.com/CVE-2022-21129/index.md","name":"CVE-2022-21129","record":{"aliases":["GHSA-c6rx-gxqv-vr5j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"npm automation library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via improper input sanitization in nemo-appium, requiring a specific dependency installation.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"nemo-appium","vendor":"paypal"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function.\r\r\r**Note:** In order to exploit this vulnerability appium-running 0.1.3  has to be installed as one of nemo-appium dependencies.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"nemo-appium vulnerable to OS Command Injection","id":"CVE-2022-21129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"** REJECT ** DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2022-21130"},"packages":[{"ecosystem":"npm","fixed":["0.0.9"],"introduced":["0"],"last_affected":[],"package":"nemo-appium","purl":null,"source":"GHSA-c6rx-gxqv-vr5j"},{"ecosystem":"npm","fixed":["0.0.9"],"introduced":["0"],"last_affected":[],"package":"nemo-appium","purl":"pkg:npm/nemo-appium","source":"GHSA-c6rx-gxqv-vr5j"}],"prev":{"headline":"Privilege escalation in Intel(R) Advisor software","id":"CVE-2022-21128"},"products":["nemo-appium"],"published":"2023-01-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via improper input sanitization in nemo-appium, requiring a specific dependency installation.","url":"https://insights.sbomify.com/CVE-2022-21129/"}