# CVE-2022-21129: nemo-appium vulnerable to OS Command Injection

> Attackers can execute arbitrary commands via improper input sanitization in nemo-appium, requiring a specific dependency installation.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jan 2023
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-c6rx-gxqv-vr5j

## What is CVE-2022-21129?

CVE-2022-21129 is a high-severity command injection vulnerability in nemo-appium, published on 31 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function.**Note:** In order to exploit this vulnerability appium-running 0.1.3  has to be installed as one of nemo-appium dependencies.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-21129?

2 open source packages ship an affected version, including nemo-appium. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nemo-appium` | npm | All versions | 0.0.9 |
| `nemo-appium` | npm | All versions | 0.0.9 |

Products: Paypal Nemo-Appium.

## How do I fix CVE-2022-21129?

Upgrade nemo-appium to 0.0.9 or later.

## Is CVE-2022-21129 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21129 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21129 and fix it if it is affected.

What it is: CVE-2022-21129 is a high-severity command injection vulnerability in nemo-appium, published on 31 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21129 exists.

Affected packages and fixed versions:
- nemo-appium (npm): affected all versions; fixed in 0.0.9
- nemo-appium (npm): affected all versions; fixed in 0.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21129/ (Markdown: https://insights.sbomify.com/CVE-2022-21129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21129
- OSV: https://osv.dev/vulnerability/CVE-2022-21129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21129/
Summaries are generated and may contain mistakes; the official description above is the record.
