{"answers":{"affected":"2 open source packages ship an affected version, including libxmljs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21144 in the wild and no public exploit code.","fix":"Upgrade libxmljs to 0.19.8 or later.","what":"CVE-2022-21144 is a high-severity denial of service vulnerability in libxmljs, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21144 and fix it if it is affected.\n\nWhat it is: CVE-2022-21144 is a high-severity denial of service vulnerability in libxmljs, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21144 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libxmljs (npm): affected all versions; fixed in 0.19.8\n- libxmljs (npm): affected all versions; fixed in 0.19.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21144/ (Markdown: https://insights.sbomify.com/CVE-2022-21144/index.md)","id":"CVE-2022-21144","markdown":"https://insights.sbomify.com/CVE-2022-21144/index.md","name":"CVE-2022-21144","record":{"aliases":["GHSA-773h-w45w-f2f9","SNYK-JS-LIBXMLJS-2348756"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js XML library","requires_auth":"none","summary":"Attackers can crash the application by passing non-buffer arguments with invalid toString methods to the parseXml function in libxmljs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"libxmljs","vendor":"libxmljs_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"This affects all versions of package libxmljs. When invoking the libxmljs.parseXml function with a non-buffer argument the V8 code will attempt invoking the .toString method of the argument. If the argument's toString value is not a Function object V8 will crash.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service (DoS)","id":"CVE-2022-21144","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in lansweeper","id":"CVE-2022-21145"},"packages":[{"ecosystem":"npm","fixed":["0.19.8"],"introduced":["0"],"last_affected":[],"package":"libxmljs","purl":null,"source":"GHSA-773h-w45w-f2f9"},{"ecosystem":"npm","fixed":["0.19.8"],"introduced":["0"],"last_affected":[],"package":"libxmljs","purl":"pkg:npm/libxmljs","source":"GHSA-773h-w45w-f2f9"}],"prev":{"headline":"Airspan Networks Mimosa OS Command Injection","id":"CVE-2022-21143"},"products":["libxmljs"],"published":"2022-05-01","related":[{"cvss_score":8.1,"headline":"libxmljs attrs type confusion RCE","id":"CVE-2024-34391","kev_date_added":null,"published":"2024-05-02"},{"cvss_score":8.1,"headline":"libxmljs namespaces type confusion RCE","id":"CVE-2024-34392","kev_date_added":null,"published":"2024-05-02"},{"cvss_score":7.5,"headline":"libxmljs has segmentation fault, potentially leading to a denial-of-service (DoS)","id":"CVE-2025-25341","kev_date_added":null,"published":"2025-12-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can crash the application by passing non-buffer arguments with invalid toString methods to the parseXml function in libxmljs.","url":"https://insights.sbomify.com/CVE-2022-21144/"}