# CVE-2022-21144: Denial of Service (DoS)

> Attackers can crash the application by passing non-buffer arguments with invalid toString methods to the parseXml function in libxmljs.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-773h-w45w-f2f9, SNYK-JS-LIBXMLJS-2348756

## What is CVE-2022-21144?

CVE-2022-21144 is a high-severity denial of service vulnerability in libxmljs, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects all versions of package libxmljs. When invoking the libxmljs.parseXml function with a non-buffer argument the V8 code will attempt invoking the .toString method of the argument. If the argument's toString value is not a Function object V8 will crash.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-21144?

2 open source packages ship an affected version, including libxmljs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libxmljs` | npm | All versions | 0.19.8 |
| `libxmljs` | npm | All versions | 0.19.8 |

Products: Libxmljs Project Libxmljs.

## How do I fix CVE-2022-21144?

Upgrade libxmljs to 0.19.8 or later.

## Is CVE-2022-21144 being exploited?

There is no known exploitation of CVE-2022-21144 in the wild and no public exploit code.

## Other vulnerabilities in libxmljs

- [CVE-2024-34391](https://insights.sbomify.com/CVE-2024-34391/): libxmljs attrs type confusion RCE (high 8.1)
- [CVE-2024-34392](https://insights.sbomify.com/CVE-2024-34392/): libxmljs namespaces type confusion RCE (high 8.1)
- [CVE-2025-25341](https://insights.sbomify.com/CVE-2025-25341/): libxmljs has segmentation fault, potentially leading to a denial-of-service (DoS) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21144 and fix it if it is affected.

What it is: CVE-2022-21144 is a high-severity denial of service vulnerability in libxmljs, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21144 in the wild and no public exploit code.

Affected packages and fixed versions:
- libxmljs (npm): affected all versions; fixed in 0.19.8
- libxmljs (npm): affected all versions; fixed in 0.19.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21144/ (Markdown: https://insights.sbomify.com/CVE-2022-21144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21144
- OSV: https://osv.dev/vulnerability/CVE-2022-21144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21144/
Summaries are generated and may contain mistakes; the official description above is the record.
