# CVE-2022-21149: Cross-site Scripting (XSS)

> Attackers can steal victim cookies via XSS to gain unauthorized account access in the S-Cart e-commerce platform.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7pfc-cx3m-v22x

## What is CVE-2022-21149?

CVE-2022-21149 is a medium-severity cross-site scripting vulnerability in s-cart/core, published on 1 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The package s-cart/s-cart before 6.9; the package s-cart/core before 6.9 are vulnerable to Cross-site Scripting (XSS) which can lead to cookie stealing of any victim that visits the affected URL so the attacker can gain unauthorized access to that user's account through the stolen cookie.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-21149?

4 open source packages ship an affected version, including s-cart/core and s-cart/s-cart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `s-cart/core` | Packagist | All versions | 6.9 |
| `s-cart/core` | Packagist | All versions | 6.9 |
| `s-cart/s-cart` | Packagist | All versions | 6.9 |
| `s-cart/s-cart` | Packagist | All versions | 6.9 |

Products: S-Cart S-Cart.

## How do I fix CVE-2022-21149?

Upgrade s-cart/core to 6.9 or later.

## Is CVE-2022-21149 being exploited?

There is no known exploitation of CVE-2022-21149 in the wild and no public exploit code.

## Other vulnerabilities in s-cart/core

- [CVE-2021-38847](https://insights.sbomify.com/CVE-2021-38847/): File upload in n/a (high 8.8)
- [CVE-2020-28456](https://insights.sbomify.com/CVE-2020-28456/): Cross-site Scripting (XSS) (high 7.3)
- [CVE-2020-28457](https://insights.sbomify.com/CVE-2020-28457/): Cross-site Scripting (XSS) (high 7.2)
- [CVE-2021-44111](https://insights.sbomify.com/CVE-2021-44111/): Path Traversal in S-Cart (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21149 and fix it if it is affected.

What it is: CVE-2022-21149 is a medium-severity cross-site scripting vulnerability in s-cart/core, published on 1 May 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-21149 in the wild and no public exploit code.

Affected packages and fixed versions:
- s-cart/core (Packagist): affected all versions; fixed in 6.9
- s-cart/core (Packagist): affected all versions; fixed in 6.9
- s-cart/s-cart (Packagist): affected all versions; fixed in 6.9
- s-cart/s-cart (Packagist): affected all versions; fixed in 6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21149/ (Markdown: https://insights.sbomify.com/CVE-2022-21149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21149
- OSV: https://osv.dev/vulnerability/CVE-2022-21149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21149/
Summaries are generated and may contain mistakes; the official description above is the record.
