{"answers":{"affected":"2 open source packages ship an affected version, including node-lmdb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21164 in the wild and no public exploit code.","fix":"Upgrade node-lmdb to 0.9.7 or later.","what":"CVE-2022-21164 is a low-severity denial of service vulnerability in node-lmdb, published on 16 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21164 and fix it if it is affected.\n\nWhat it is: CVE-2022-21164 is a low-severity denial of service vulnerability in node-lmdb, published on 16 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21164 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-lmdb (npm): affected all versions; fixed in 0.9.7\n- node-lmdb (npm): affected all versions; fixed in 0.9.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21164/ (Markdown: https://insights.sbomify.com/CVE-2022-21164/index.md)","id":"CVE-2022-21164","markdown":"https://insights.sbomify.com/CVE-2022-21164/index.md","name":"CVE-2022-21164","record":{"aliases":["GHSA-32j9-6qqm-mq9g","SNYK-JS-NODELMDB-2400723"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js LMDB library","requires_auth":"none","summary":"An attacker can cause a crash in the node-lmdb library by providing a non-invokable ToString value, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"node-lmdb","vendor":"node-lmdb_project"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P","version":"3.1"},"cwes":[],"description":"The package node-lmdb before 0.9.7 are vulnerable to Denial of Service (DoS) when defining a non-invokable ToString value, which will cause a crash during type check.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service (DoS)","id":"CVE-2022-21164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Arbitrary Command Injection","id":"CVE-2022-21165"},"packages":[{"ecosystem":"npm","fixed":["0.9.7"],"introduced":["0"],"last_affected":[],"package":"node-lmdb","purl":null,"source":"GHSA-32j9-6qqm-mq9g"},{"ecosystem":"npm","fixed":["0.9.7"],"introduced":["0"],"last_affected":[],"package":"node-lmdb","purl":"pkg:npm/node-lmdb","source":"GHSA-32j9-6qqm-mq9g"}],"prev":{"headline":"Privilege escalation in Crypto API Toolkit for Intel(R) SGX","id":"CVE-2022-21163"},"products":["node-lmdb"],"published":"2022-03-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker can cause a crash in the node-lmdb library by providing a non-invokable ToString value, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2022-21164/"}