# CVE-2022-21169: Prototype Pollution

> Attackers can bypass XSS sanitization via prototype pollution in the express-xss-sanitizer library, potentially allowing malicious script execution.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2022
- **Updated:** 21 May 2025
- **Also known as:** GHSA-grjp-4jmr-mjcw

## What is CVE-2022-21169?

CVE-2022-21169 is a high-severity vulnerability in express-xss-sanitizer, published on 26 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package express-xss-sanitizer before 1.1.3 are vulnerable to Prototype Pollution via the allowedTags attribute, allowing the attacker to bypass xss sanitization.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-21169?

2 open source packages ship an affected version, including express-xss-sanitizer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-xss-sanitizer` | npm | All versions | 1.1.3 |
| `express-xss-sanitizer` | npm | All versions | 1.1.3 |

Products: Express Xss Sanitizer Project Express Xss Sanitizer.

## How do I fix CVE-2022-21169?

Upgrade express-xss-sanitizer to 1.1.3 or later.

## Is CVE-2022-21169 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21169 exists.

## Other vulnerabilities in express-xss-sanitizer

- [CVE-2026-33979](https://insights.sbomify.com/CVE-2026-33979/): Express XSS Sanitizer: allowedTags/allowedAttributes bypass leads to permissive sanitization (XSS risk) (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21169 and fix it if it is affected.

What it is: CVE-2022-21169 is a high-severity vulnerability in express-xss-sanitizer, published on 26 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21169 exists.

Affected packages and fixed versions:
- express-xss-sanitizer (npm): affected all versions; fixed in 1.1.3
- express-xss-sanitizer (npm): affected all versions; fixed in 1.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21169/ (Markdown: https://insights.sbomify.com/CVE-2022-21169/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21169
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21169
- OSV: https://osv.dev/vulnerability/CVE-2022-21169

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21169/
Summaries are generated and may contain mistakes; the official description above is the record.
