{"answers":{"affected":"2 open source packages ship an affected version, including @acrontum/filesystem-template. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21186 in the wild and no public exploit code.","fix":"Upgrade @acrontum/filesystem-template to 0.0.2 or later.","what":"CVE-2022-21186 is a critical command injection vulnerability in @acrontum/filesystem-template, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21186 and fix it if it is affected.\n\nWhat it is: CVE-2022-21186 is a critical command injection vulnerability in @acrontum/filesystem-template, published on 5 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21186 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @acrontum/filesystem-template (npm): affected all versions; fixed in 0.0.2\n- @acrontum/filesystem-template (npm): affected all versions; fixed in 0.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21186/ (Markdown: https://insights.sbomify.com/CVE-2022-21186/index.md)","id":"CVE-2022-21186","markdown":"https://insights.sbomify.com/CVE-2022-21186/index.md","name":"CVE-2022-21186","record":{"aliases":["GHSA-m2fc-9h5m-29cm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm filesystem library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via unsanitized input in the fetchRepo API of the @acrontum/filesystem-template npm package.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"filesystem-template","vendor":"acrontum"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[],"description":"The package @acrontum/filesystem-template before 0.0.2 are vulnerable to Arbitrary Command Injection due to the fetchRepo API missing sanitization of the href field of external input.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary Command Injection","id":"CVE-2022-21186","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Command Injection","id":"CVE-2022-21187"},"packages":[{"ecosystem":"npm","fixed":["0.0.2"],"introduced":["0"],"last_affected":[],"package":"@acrontum/filesystem-template","purl":null,"source":"GHSA-m2fc-9h5m-29cm"},{"ecosystem":"npm","fixed":["0.0.2"],"introduced":["0"],"last_affected":[],"package":"@acrontum/filesystem-template","purl":"pkg:npm/%40acrontum/filesystem-template","source":"GHSA-m2fc-9h5m-29cm"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-21185"},"products":["@acrontum/filesystem-template"],"published":"2022-08-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via unsanitized input in the fetchRepo API of the @acrontum/filesystem-template npm package.","url":"https://insights.sbomify.com/CVE-2022-21186/"}