{"answers":{"affected":"6 open source packages ship an affected version, including libvcs and vcspull. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21187 in the wild and no public exploit code.","fix":"Upgrade libvcs to 0.11.1 or later.","what":"CVE-2022-21187 is a high-severity command injection vulnerability in libvcs, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21187 and fix it if it is affected.\n\nWhat it is: CVE-2022-21187 is a high-severity command injection vulnerability in libvcs, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21187 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libvcs (PyPI): affected all versions; fixed in 0.11.1\n- libvcs (PyPI): affected all versions; fixed in 0.11.1\n- libvcs (PyPI): affected all versions; fixed in 0.11.1\n- vcspull (PyPI): affected all versions; fixed in 1.11.1\n- vcspull (PyPI): affected all versions; fixed in 1.11.1\n- vcspull (PyPI): affected all versions; fixed in 1.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21187/ (Markdown: https://insights.sbomify.com/CVE-2022-21187/index.md)","id":"CVE-2022-21187","markdown":"https://insights.sbomify.com/CVE-2022-21187/index.md","name":"CVE-2022-21187","record":{"aliases":["GHSA-mv2w-4jqc-6fg4","PYSEC-2022-163","PYSEC-2026-563","SNYK-PYTHON-LIBVCS-2421204"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python VCS library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via argument injection in the hg clone function of the libvcs Python library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"libvcs","vendor":"libvcs_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection","id":"CVE-2022-21187","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":6,"n_references":3,"next":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-21188"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0"],"last_affected":[],"package":"libvcs","purl":null,"source":"GHSA-mv2w-4jqc-6fg4"},{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0"],"last_affected":[],"package":"libvcs","purl":"pkg:pypi/libvcs","source":"GHSA-mv2w-4jqc-6fg4"},{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0"],"last_affected":[],"package":"libvcs","purl":"pkg:pypi/libvcs","source":"PYSEC-2022-163"},{"ecosystem":"PyPI","fixed":["1.11.1"],"introduced":["0"],"last_affected":[],"package":"vcspull","purl":null,"source":"GHSA-mv2w-4jqc-6fg4"},{"ecosystem":"PyPI","fixed":["1.11.1"],"introduced":["0"],"last_affected":[],"package":"vcspull","purl":"pkg:pypi/vcspull","source":"GHSA-mv2w-4jqc-6fg4"},{"ecosystem":"PyPI","fixed":["1.11.1"],"introduced":["0"],"last_affected":[],"package":"vcspull","purl":"pkg:pypi/vcspull","source":"PYSEC-2026-563"}],"prev":{"headline":"Arbitrary Command Injection","id":"CVE-2022-21186"},"products":["libvcs"],"published":"2022-03-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via argument injection in the hg clone function of the libvcs Python library.","url":"https://insights.sbomify.com/CVE-2022-21187/"}