# CVE-2022-21187: Command Injection

> Attackers can execute arbitrary commands via argument injection in the hg clone function of the libvcs Python library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-mv2w-4jqc-6fg4, PYSEC-2022-163, PYSEC-2026-563, SNYK-PYTHON-LIBVCS-2421204

## What is CVE-2022-21187?

CVE-2022-21187 is a high-severity command injection vulnerability in libvcs, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-21187?

6 open source packages ship an affected version, including libvcs and vcspull. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libvcs` | PyPI | All versions | 0.11.1 |
| `libvcs` | PyPI | All versions | 0.11.1 |
| `libvcs` | PyPI | All versions | 0.11.1 |
| `vcspull` | PyPI | All versions | 1.11.1 |
| `vcspull` | PyPI | All versions | 1.11.1 |
| `vcspull` | PyPI | All versions | 1.11.1 |

Products: Libvcs Project Libvcs.

## How do I fix CVE-2022-21187?

Upgrade libvcs to 0.11.1 or later.

## Is CVE-2022-21187 being exploited?

There is no known exploitation of CVE-2022-21187 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21187 and fix it if it is affected.

What it is: CVE-2022-21187 is a high-severity command injection vulnerability in libvcs, published on 14 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21187 in the wild and no public exploit code.

Affected packages and fixed versions:
- libvcs (PyPI): affected all versions; fixed in 0.11.1
- libvcs (PyPI): affected all versions; fixed in 0.11.1
- libvcs (PyPI): affected all versions; fixed in 0.11.1
- vcspull (PyPI): affected all versions; fixed in 1.11.1
- vcspull (PyPI): affected all versions; fixed in 1.11.1
- vcspull (PyPI): affected all versions; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21187/ (Markdown: https://insights.sbomify.com/CVE-2022-21187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21187
- OSV: https://osv.dev/vulnerability/CVE-2022-21187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21187/
Summaries are generated and may contain mistakes; the official description above is the record.
