# CVE-2022-21189: Prototype Pollution

> Attackers can pollute Object.prototype via untrusted input in Dexie, potentially leading to code execution or security bypasses.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-3xgx-r9j4-qw9w

## What is CVE-2022-21189?

CVE-2022-21189 is a high-severity vulnerability in dexie, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package dexie before 3.2.2, from 4.0.0-alpha.1 and before 4.0.0-alpha.3 are vulnerable to Prototype Pollution in the Dexie.setByKeyPath(obj, keyPath, value) function which does not properly check the keys being set (like __proto__ or constructor). This can allow an attacker to add/modify properties of the Object.prototype leading to prototype pollution vulnerability. **Note:** This vulnerability can occur in multiple ways, for example when modifying a collection with untrusted user input.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-21189?

4 open source packages ship an affected version, including dexie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dexie` | npm | All versions | 3.2.2 |
| `dexie` | npm | All versions | 3.2.2 |
| `dexie` | npm | From 4.0.0-alpha.1 | 4.0.0-alpha.3 |
| `dexie` | npm | From 4.0.0-alpha.1 | 4.0.0-alpha.3 |

Products: Dexie Dexie.

## How do I fix CVE-2022-21189?

Upgrade dexie to a fixed version for your release line: 3.2.2 or 4.0.0-alpha.3.

## Is CVE-2022-21189 being exploited?

There is no known exploitation of CVE-2022-21189 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21189 and fix it if it is affected.

What it is: CVE-2022-21189 is a high-severity vulnerability in dexie, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21189 in the wild and no public exploit code.

Affected packages and fixed versions:
- dexie (npm): affected all versions; fixed in 3.2.2
- dexie (npm): affected all versions; fixed in 3.2.2
- dexie (npm): affected from 4.0.0-alpha.1; fixed in 4.0.0-alpha.3
- dexie (npm): affected from 4.0.0-alpha.1; fixed in 4.0.0-alpha.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21189/ (Markdown: https://insights.sbomify.com/CVE-2022-21189/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21189
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21189
- OSV: https://osv.dev/vulnerability/CVE-2022-21189

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21189/
Summaries are generated and may contain mistakes; the official description above is the record.
