{"answers":{"affected":"2 open source packages ship an affected version, including global-modules-path. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21191 in the wild and no public exploit code.","fix":"Upgrade global-modules-path to 3.0.0 or later.","what":"CVE-2022-21191 is a high-severity command injection vulnerability in global-modules-path, published on 13 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21191 and fix it if it is affected.\n\nWhat it is: CVE-2022-21191 is a high-severity command injection vulnerability in global-modules-path, published on 13 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- global-modules-path (npm): affected all versions; fixed in 3.0.0\n- global-modules-path (npm): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21191/ (Markdown: https://insights.sbomify.com/CVE-2022-21191/index.md)","id":"CVE-2022-21191","markdown":"https://insights.sbomify.com/CVE-2022-21191/index.md","name":"CVE-2022-21191","record":{"aliases":["GHSA-vvj3-85vf-fgmw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"npm library","requires_auth":"none","summary":"Attackers can execute arbitrary commands via the getPath function in the global-modules-path npm library due to missing input sanitization.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"global-modules-path","vendor":"global-modules-path_project"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Versions of the package global-modules-path before 3.0.0 are vulnerable to Command Injection due to missing input sanitization or other checks and sandboxes being employed to the getPath  function.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"global-modules-path Command Injection vulnerability","id":"CVE-2022-21191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Directory Traversal vulnerability in serve-lite","id":"CVE-2022-21192"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"global-modules-path","purl":null,"source":"GHSA-vvj3-85vf-fgmw"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"global-modules-path","purl":"pkg:npm/global-modules-path","source":"GHSA-vvj3-85vf-fgmw"}],"prev":{"headline":"Prototype Pollution","id":"CVE-2022-21190"},"products":["global-modules-path"],"published":"2023-01-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via the getPath function in the global-modules-path npm library due to missing input sanitization.","url":"https://insights.sbomify.com/CVE-2022-21191/"}