# CVE-2022-21191: global-modules-path Command Injection vulnerability

> Attackers can execute arbitrary commands via the getPath function in the global-modules-path npm library due to missing input sanitization.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2023
- **Updated:** 4 Apr 2025
- **Also known as:** GHSA-vvj3-85vf-fgmw

## What is CVE-2022-21191?

CVE-2022-21191 is a high-severity command injection vulnerability in global-modules-path, published on 13 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Versions of the package global-modules-path before 3.0.0 are vulnerable to Command Injection due to missing input sanitization or other checks and sandboxes being employed to the getPath  function.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-21191?

2 open source packages ship an affected version, including global-modules-path. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `global-modules-path` | npm | All versions | 3.0.0 |
| `global-modules-path` | npm | All versions | 3.0.0 |

Products: Global-Modules-Path Project Global-Modules-Path.

## How do I fix CVE-2022-21191?

Upgrade global-modules-path to 3.0.0 or later.

## Is CVE-2022-21191 being exploited?

There is no known exploitation of CVE-2022-21191 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21191 and fix it if it is affected.

What it is: CVE-2022-21191 is a high-severity command injection vulnerability in global-modules-path, published on 13 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21191 in the wild and no public exploit code.

Affected packages and fixed versions:
- global-modules-path (npm): affected all versions; fixed in 3.0.0
- global-modules-path (npm): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21191/ (Markdown: https://insights.sbomify.com/CVE-2022-21191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21191
- OSV: https://osv.dev/vulnerability/CVE-2022-21191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21191/
Summaries are generated and may contain mistakes; the official description above is the record.
