{"answers":{"affected":"2 open source packages ship an affected version, including node-opcua. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-21208 in the wild and no public exploit code.","fix":"Upgrade node-opcua to 2.74.0 or later.","what":"CVE-2022-21208 is a high-severity denial of service vulnerability in node-opcua, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21208 and fix it if it is affected.\n\nWhat it is: CVE-2022-21208 is a high-severity denial of service vulnerability in node-opcua, published on 23 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21208 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-opcua (npm): affected all versions; fixed in 2.74.0\n- node-opcua (npm): affected all versions; fixed in 2.74.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21208/ (Markdown: https://insights.sbomify.com/CVE-2022-21208/index.md)","id":"CVE-2022-21208","markdown":"https://insights.sbomify.com/CVE-2022-21208/index.md","name":"CVE-2022-21208","record":{"aliases":["GHSA-4hr4-pjjh-2q2w"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js OPC UA library","requires_auth":"none","summary":"An attacker can cause a denial of service in node-opcua by sending unlimited large chunks without closing the session, exhausting resources.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"node-opcua","vendor":"node-opcua_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P","version":"3.1"},"cwes":[{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"}],"description":"The package node-opcua before 2.74.0 are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service (DoS)","id":"CVE-2022-21208","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"ICSA-22-055-01 FATEK Automation FvDesigner","id":"CVE-2022-21209"},"packages":[{"ecosystem":"npm","fixed":["2.74.0"],"introduced":["0"],"last_affected":[],"package":"node-opcua","purl":null,"source":"GHSA-4hr4-pjjh-2q2w"},{"ecosystem":"npm","fixed":["2.74.0"],"introduced":["0"],"last_affected":[],"package":"node-opcua","purl":"pkg:npm/node-opcua","source":"GHSA-4hr4-pjjh-2q2w"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-21207"},"products":["node-opcua"],"published":"2022-08-23","related":[{"cvss_score":7.5,"headline":"Denial of Service (DoS)","id":"CVE-2022-24375","kev_date_added":null,"published":"2022-08-24"},{"cvss_score":7.5,"headline":"Denial of Service (DoS)","id":"CVE-2022-25231","kev_date_added":null,"published":"2022-08-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in node-opcua by sending unlimited large chunks without closing the session, exhausting resources.","url":"https://insights.sbomify.com/CVE-2022-21208/"}