# CVE-2022-21213: Prototype Pollution

> Prototype pollution in mout library allows attackers to modify object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2022
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1773101697, CLSA-2026-1789161495, GHSA-vvv8-xw5f-3f88

## What is CVE-2022-21213?

CVE-2022-21213 is a high-severity vulnerability in mout, published on 17 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This affects all versions of package mout. The deepFillIn function can be used to 'fill missing properties recursively', while the deepMixIn mixes objects into the target object, recursively mixing existing child objects as well. In both cases, the key used to access the target object recursively is not checked, leading to exploiting this vulnerability. **Note:** This vulnerability derives from an incomplete fix of [CVE-2020-7792](https://security.snyk.io/vuln/SNYK-JS-MOUT-1014544).

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-21213?

2 open source packages ship an affected version, including mout. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mout` | npm | All versions | 1.2.4 |
| `mout` | npm | All versions | 1.2.4 |

Products: Moutjs Mout.

## How do I fix CVE-2022-21213?

Upgrade mout to 1.2.4 or later.

## Is CVE-2022-21213 being exploited?

There is no known exploitation of CVE-2022-21213 in the wild and no public exploit code.

## Other vulnerabilities in mout

- [CVE-2020-7792](https://insights.sbomify.com/CVE-2020-7792/): Prototype Pollution (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21213 and fix it if it is affected.

What it is: CVE-2022-21213 is a high-severity vulnerability in mout, published on 17 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21213 in the wild and no public exploit code.

Affected packages and fixed versions:
- mout (npm): affected all versions; fixed in 1.2.4
- mout (npm): affected all versions; fixed in 1.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21213/ (Markdown: https://insights.sbomify.com/CVE-2022-21213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21213
- OSV: https://osv.dev/vulnerability/CVE-2022-21213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21213/
Summaries are generated and may contain mistakes; the official description above is the record.
