{"answers":{"affected":"2 open source packages ship an affected version, including css-what. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21222 exists.","fix":"Upgrade css-what to 2.1.3 or later.","what":"CVE-2022-21222 is a medium-severity denial of service vulnerability in css-what, published on 30 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21222 and fix it if it is affected.\n\nWhat it is: CVE-2022-21222 is a medium-severity denial of service vulnerability in css-what, published on 30 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21222 exists.\n\nAffected packages and fixed versions:\n- css-what (npm): affected all versions; fixed in 2.1.3\n- css-what (npm): affected all versions; fixed in 2.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21222/ (Markdown: https://insights.sbomify.com/CVE-2022-21222/index.md)","id":"CVE-2022-21222","markdown":"https://insights.sbomify.com/CVE-2022-21222/index.md","name":"CVE-2022-21222","record":{"aliases":["DEBIAN-CVE-2022-21222","GHSA-p28h-cc7q-c4fg","UBUNTU-CVE-2022-21222"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"CSS selector parser","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the css-what library by triggering a regular expression denial of service via the parse function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[{"product":"css-what","vendor":"css-what_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2022-21222","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Command Injection","id":"CVE-2022-21223"},"packages":[{"ecosystem":"npm","fixed":["2.1.3"],"introduced":["0"],"last_affected":[],"package":"css-what","purl":null,"source":"GHSA-p28h-cc7q-c4fg"},{"ecosystem":"npm","fixed":["2.1.3"],"introduced":["0"],"last_affected":[],"package":"css-what","purl":"pkg:npm/css-what","source":"GHSA-p28h-cc7q-c4fg"}],"prev":{"headline":"Directory Traversal","id":"CVE-2022-21221"},"products":["css-what"],"published":"2022-09-30","related":[{"cvss_score":7.5,"headline":"Denial of service in css-what","id":"CVE-2021-33587","kev_date_added":null,"published":"2021-05-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-20","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using the css-what library by triggering a regular expression denial of service via the parse function.","url":"https://insights.sbomify.com/CVE-2022-21222/"}