# CVE-2022-21222: Regular Expression Denial of Service (ReDoS)

> An attacker can cause a denial of service in applications using the css-what library by triggering a regular expression denial of service via the parse function.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2022
- **Updated:** 20 May 2025
- **Also known as:** DEBIAN-CVE-2022-21222, GHSA-p28h-cc7q-c4fg, UBUNTU-CVE-2022-21222

## What is CVE-2022-21222?

CVE-2022-21222 is a medium-severity denial of service vulnerability in css-what, published on 30 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-21222?

2 open source packages ship an affected version, including css-what. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `css-what` | npm | All versions | 2.1.3 |
| `css-what` | npm | All versions | 2.1.3 |

Products: Css-What Project Css-What.

## How do I fix CVE-2022-21222?

Upgrade css-what to 2.1.3 or later.

## Is CVE-2022-21222 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21222 exists.

## Other vulnerabilities in css-what

- [CVE-2021-33587](https://insights.sbomify.com/CVE-2021-33587/): Denial of service in css-what (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21222 and fix it if it is affected.

What it is: CVE-2022-21222 is a medium-severity denial of service vulnerability in css-what, published on 30 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-21222 exists.

Affected packages and fixed versions:
- css-what (npm): affected all versions; fixed in 2.1.3
- css-what (npm): affected all versions; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21222/ (Markdown: https://insights.sbomify.com/CVE-2022-21222/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21222
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21222
- OSV: https://osv.dev/vulnerability/CVE-2022-21222

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21222/
Summaries are generated and may contain mistakes; the official description above is the record.
