# CVE-2022-21223: Command Injection

> Attackers can execute arbitrary commands via argument injection in the hg download function of the cocoapods-downloader Ruby library.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-g397-v4w5-4m79, SNYK-RUBY-COCOAPODSDOWNLOADER-2414280

## What is CVE-2022-21223?

CVE-2022-21223 is a high-severity command injection vulnerability in cocoapods-downloader, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package cocoapods-downloader before 1.6.2 are vulnerable to Command Injection via hg argument injection. When calling the download function (when using hg), the url (and/or revision, tag, branch) is passed to the hg clone command in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-21223?

2 open source packages ship an affected version, including cocoapods-downloader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cocoapods-downloader` | RubyGems | All versions | 1.6.2 |
| `cocoapods-downloader` | RubyGems | All versions | 1.6.2 |

Products: Cocoapods Cocoapods-Downloader.

## How do I fix CVE-2022-21223?

Upgrade cocoapods-downloader to 1.6.2 or later.

## Is CVE-2022-21223 being exploited?

There is no known exploitation of CVE-2022-21223 in the wild and no public exploit code.

## Other vulnerabilities in cocoapods-downloader

- [CVE-2022-24440](https://insights.sbomify.com/CVE-2022-24440/): Command Injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21223 and fix it if it is affected.

What it is: CVE-2022-21223 is a high-severity command injection vulnerability in cocoapods-downloader, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21223 in the wild and no public exploit code.

Affected packages and fixed versions:
- cocoapods-downloader (RubyGems): affected all versions; fixed in 1.6.2
- cocoapods-downloader (RubyGems): affected all versions; fixed in 1.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21223/ (Markdown: https://insights.sbomify.com/CVE-2022-21223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21223
- OSV: https://osv.dev/vulnerability/CVE-2022-21223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21223/
Summaries are generated and may contain mistakes; the official description above is the record.
