# CVE-2022-21227: Denial of Service (DoS)

> An attacker can cause a Denial of Service by passing an invalid Function object to the sqlite3 library, crashing the V8 engine.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2022
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2022-21227, GHSA-9qrh-qjmc-5w2p, UBUNTU-CVE-2022-21227

## What is CVE-2022-21227?

CVE-2022-21227 is a high-severity denial of service vulnerability in sqlite3, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. If passed an invalid Function object it will throw and crash the V8 engine.

## Which versions are affected by CVE-2022-21227?

2 open source packages ship an affected version, including sqlite3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sqlite3` | npm | From 5.0.0 | 5.0.3 |
| `sqlite3` | npm | From 5.0.0 | 5.0.3 |

Products: Ghost Sqlite3.

## How do I fix CVE-2022-21227?

Upgrade sqlite3 to 5.0.3 or later.

## Is CVE-2022-21227 being exploited?

There is no known exploitation of CVE-2022-21227 in the wild and no public exploit code.

## Other vulnerabilities in sqlite3

- [CVE-2022-43441](https://insights.sbomify.com/CVE-2022-43441/): sqlite vulnerable to code execution due to Object coercion (high 8.1)
- [CVE-2020-24736](https://insights.sbomify.com/CVE-2020-24736/): Memory corruption in n/a (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21227 and fix it if it is affected.

What it is: CVE-2022-21227 is a high-severity denial of service vulnerability in sqlite3, published on 1 May 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21227 in the wild and no public exploit code.

Affected packages and fixed versions:
- sqlite3 (npm): affected from 5.0.0; fixed in 5.0.3
- sqlite3 (npm): affected from 5.0.0; fixed in 5.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21227/ (Markdown: https://insights.sbomify.com/CVE-2022-21227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21227
- OSV: https://osv.dev/vulnerability/CVE-2022-21227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21227/
Summaries are generated and may contain mistakes; the official description above is the record.
