# CVE-2022-21235: Command Injection

> Attackers can execute arbitrary commands via argument injection when the library invokes the Mercurial hg command.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-6635-c626-vj4r, GO-2022-0414, SNYK-GOLANG-GITHUBCOMMASTERMINDSVCS-2437078

## What is CVE-2022-21235?

CVE-2022-21235 is a high-severity command injection vulnerability in github.com/Masterminds/vcs, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The package github.com/masterminds/vcs before 1.13.3 are vulnerable to Command Injection via argument injection. When hg is executed, argument strings are passed to hg in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2022-21235?

3 open source packages ship an affected version, including github.com/Masterminds/vcs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/Masterminds/vcs` | Go | All versions | 1.13.2 |
| `github.com/Masterminds/vcs` | Go | All versions | 1.13.2 |
| `github.com/Masterminds/vcs` | Go | All versions | 1.13.3 |

Products: Vcs Project Vcs.

## How do I fix CVE-2022-21235?

Upgrade github.com/Masterminds/vcs to a fixed version for your release line: 1.13.2 or 1.13.3.

## Is CVE-2022-21235 being exploited?

There is no known exploitation of CVE-2022-21235 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21235 and fix it if it is affected.

What it is: CVE-2022-21235 is a high-severity command injection vulnerability in github.com/Masterminds/vcs, published on 1 Apr 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21235 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/Masterminds/vcs (Go): affected all versions; fixed in 1.13.2
- github.com/Masterminds/vcs (Go): affected all versions; fixed in 1.13.2
- github.com/Masterminds/vcs (Go): affected all versions; fixed in 1.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21235/ (Markdown: https://insights.sbomify.com/CVE-2022-21235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21235
- OSV: https://osv.dev/vulnerability/CVE-2022-21235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21235/
Summaries are generated and may contain mistakes; the official description above is the record.
