{"answers":{"affected":"2 open source packages ship an affected version, including mysql:mysql-connector-java. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-21363 in the wild and no public exploit code.","fix":"Upgrade mysql:mysql-connector-java to 8.0.28 or later.","what":"CVE-2022-21363 is a medium-severity vulnerability in Oracle Corporation MySQL Connectors, published on 19 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-21363 and fix it if it is affected.\n\nWhat it is: CVE-2022-21363 is a medium-severity vulnerability in Oracle Corporation MySQL Connectors, published on 19 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-21363 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mysql:mysql-connector-java (Maven): affected all versions; fixed in 8.0.28\n- mysql:mysql-connector-java (Maven): affected all versions; fixed in 8.0.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-21363/ (Markdown: https://insights.sbomify.com/CVE-2022-21363/index.md)","id":"CVE-2022-21363","markdown":"https://insights.sbomify.com/CVE-2022-21363/index.md","name":"CVE-2022-21363","record":{"aliases":["AZL-7739","GHSA-g76j-4cxx-23h9","UBUNTU-CVE-2022-21363"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"MySQL Connector/J","requires_auth":"high_privilege","summary":"A difficult-to-exploit vulnerability in MySQL Connector/J allows high-privileged attackers to compromise the connector, leading to takeover.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"oracle","cpe":[{"product":"mysql_connectors","vendor":"oracle"},{"product":"quarkus","vendor":"quarkus"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Vulnerability in the MySQL Connectors product of Oracle MySQL (component: Connector/J). Supported versions that are affected are 8.0.27 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successful attacks of this vulnerability can result in takeover of MySQL Connectors. CVSS 3.1 Base Score 6.6 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H).","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Handling of Insufficient Permissions or Privileges in MySQL Connectors Java","id":"CVE-2022-21363","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Information disclosure in PeopleSoft Enterprise PT PeopleTools","id":"CVE-2022-21364"},"packages":[{"ecosystem":"Maven","fixed":["8.0.28"],"introduced":["0"],"last_affected":[],"package":"mysql:mysql-connector-java","purl":null,"source":"GHSA-g76j-4cxx-23h9"},{"ecosystem":"Maven","fixed":["8.0.28"],"introduced":["0"],"last_affected":[],"package":"mysql:mysql-connector-java","purl":"pkg:maven/mysql/mysql-connector-java","source":"GHSA-g76j-4cxx-23h9"}],"prev":{"headline":"Denial of service in MySQL Server","id":"CVE-2022-21362"},"products":["MySQL Connectors"],"published":"2022-01-19","related":[{"cvss_score":6.4,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Oracle MySQL Connectors Java","id":"CVE-2017-3586","kev_date_added":null,"published":"2017-04-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-24","vendors":["Oracle Corporation"]},"summary":"A difficult-to-exploit vulnerability in MySQL Connector/J allows high-privileged attackers to compromise the connector, leading to takeover.","url":"https://insights.sbomify.com/CVE-2022-21363/"}