CVE-2022-21427 Denial of service in MySQL Server
A high-privileged attacker can cause a complete denial of service in MySQL Server via the Full-Text Search component.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-21427?
CVE-2022-21427 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 19 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Vulnerability in the MySQL Server product of Oracle MySQL (component: Server: FTS). Supported versions that are affected are 5.7.37 and prior and 8.0.28 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
Which versions are affected by CVE-2022-21427?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 7 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.7 |
mariadb-min Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.7 |
mysql-client Bitnami | All versions | 10.2.44, 10.3.35, 10.4.25, 10.5.7 |
Products include Debian Debian Linux, Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter and 1 more.
How do I fix CVE-2022-21427?
Upgrade mariadb to a fixed version for your release line: 10.2.44, 10.3.35, 10.4.25 or 10.5.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-21427 being exploited?
There is no known exploitation of CVE-2022-21427 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-21427, AZL-9494, BIT-mariadb-2022-21427, BIT-mariadb-min-2022-21427, BIT-mysql-client-2022-21427, DEBIAN-CVE-2022-21427 and 2 more.