CVE-2022-21451 Denial of service in MySQL Server
A high-privileged attacker can cause a complete denial of service in MySQL Server via network access, requiring a patch to restore availability.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-21451?
CVE-2022-21451 is a medium-severity denial of service vulnerability in Mariadb Mariadb, published on 19 Apr 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.7.37 and prior and 8.0.28 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
Which versions are affected by CVE-2022-21451?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.2.38, 10.3.29, 10.4.19, 10.5.10 |
mariadb-min Bitnami | All versions | 10.2.38, 10.3.29, 10.4.19, 10.5.10 |
mysql-client Bitnami | All versions | 10.2.38, 10.3.29, 10.4.19, 10.5.10 |
Products include Mariadb Mariadb, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Oracle Mysql.
How do I fix CVE-2022-21451?
Upgrade mariadb to a fixed version for your release line: 10.2.38, 10.3.29, 10.4.19 or 10.5.10.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-21451 being exploited?
There is no known exploitation of CVE-2022-21451 in the wild and no public exploit code.
Other vulnerabilities in Mariadb Mariadb
- CVE-2026-49261 MariaDB server has unsafe parameter handling in `wsrep_notify_cmd`
- CVE-2026-85746 MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections
- CVE-2026-85748 MariaDB: Use-after-free with a large number of SYS_REFCURSOR's
- CVE-2026-92262 MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass.
- CVE-2023-26785 Code injection in n/a
Sources
Also known as AZL-9551, BIT-mariadb-2022-21451, BIT-mariadb-min-2022-21451, BIT-mysql-client-2022-21451, GHSA-3crw-xq5c-jr37, UBUNTU-CVE-2022-21451.