# CVE-2022-21535: Denial of service in MySQL Server

> An unauthenticated attacker with local access can cause a partial denial of service in MySQL Shell through difficult-to-exploit means requiring user interaction.

- **Severity:** Low 2.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jul 2022
- **Updated:** 24 Sep 2024
- **Also known as:** BIT-mysql-shell-2022-21535, GHSA-wmc6-mxq3-q9c7

## What is CVE-2022-21535?

CVE-2022-21535 is a low-severity denial of service vulnerability in Oracle Corporation MySQL Server, published on 19 Jul 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Vulnerability in the MySQL Shell product of Oracle MySQL (component: Shell: General/Core Client). Supported versions that are affected are 8.0.28 and prior. Difficult to exploit vulnerability allows unauthenticated attacker with logon to the infrastructure where MySQL Shell executes to compromise MySQL Shell. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Shell. CVSS 3.1 Base Score 2.5 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L).

## Which versions are affected by CVE-2022-21535?

1 open source package ship an affected version, including mysql-shell. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mysql-shell` | Bitnami | All versions | 8.0.29 |

Products: Oracle Mysql Shell.

## How do I fix CVE-2022-21535?

Upgrade mysql-shell to 8.0.29 or later.

## Is CVE-2022-21535 being exploited?

There is no known exploitation of CVE-2022-21535 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Corporation MySQL Server

- [CVE-2026-46850](https://insights.sbomify.com/CVE-2026-46850/): Code injection in MySQL Shell (critical 9.9)
- [CVE-2026-46870](https://insights.sbomify.com/CVE-2026-46870/): Auth bypass in MySQL Shell (high 8.5)
- [CVE-2026-46869](https://insights.sbomify.com/CVE-2026-46869/): Cross-site request forgery in MySQL Shell (medium 6.5)
- [CVE-2026-46871](https://insights.sbomify.com/CVE-2026-46871/): Missing authorization in MySQL Shell (medium 6.5)
- [CVE-2022-21555](https://insights.sbomify.com/CVE-2022-21555/): Missing authorization in MySQL Server (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21535 and fix it if it is affected.

What it is: CVE-2022-21535 is a low-severity denial of service vulnerability in Oracle Corporation MySQL Server, published on 19 Jul 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-21535 in the wild and no public exploit code.

Affected packages and fixed versions:
- mysql-shell (Bitnami): affected all versions; fixed in 8.0.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21535/ (Markdown: https://insights.sbomify.com/CVE-2022-21535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21535
- OSV: https://osv.dev/vulnerability/CVE-2022-21535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21535/
Summaries are generated and may contain mistakes; the official description above is the record.
