# CVE-2022-21549: Deserialization in Java SE JDK and JRE

> Unauthenticated attackers can modify data in Oracle Java SE and GraalVM via deserialization flaws in the Libraries component.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2022
- **Updated:** 27 May 2026
- **Also known as:** BIT-java-2022-21549, BIT-java-min-2022-21549, BIT-jre-2022-21549, CLEANSTART-2026-JX14846, DEBIAN-CVE-2022-21549, GHSA-c786-7jf2-46w9, MINI-8jmw-ffrp-33jp, MINI-c82q-x8jr-fjmw, MINI-fgxf-j444-fgp8, MINI-h8pm-5fj4-fjrr, MINI-q3m5-43wq-r8h7, UBUNTU-CVE-2022-21549

## What is CVE-2022-21549?

CVE-2022-21549 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Oracle Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: Libraries). Supported versions that are affected are Oracle Java SE: 17.0.3.1; Oracle GraalVM Enterprise Edition: 21.3.2 and 22.1.0. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Oracle Java SE, Oracle GraalVM Enterprise Edition accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS 3.1 Base Score 5.3 (Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N).

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-21549?

3 open source packages ship an affected version, including java, java-min and jre. It affects 14 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | From 12.0.0 | 17.0.4 |
| `java-min` | Bitnami | From 12.0.0 | 17.0.4 |
| `jre` | Bitnami | From 12.0.0 | 17.0.4 |

Products: Azul Zulu, Debian Debian Linux, Fedoraproject Fedora, Netapp 7-Mode Transition Tool, Netapp Active Iq Unified Manager, Netapp Cloud Insights Acquisition Unit, Netapp Cloud Secure Agent, Netapp Hci Compute Node, Netapp Hci Management Node, Netapp Oncommand Insight, Netapp Solidfire, Oracle Graalvm, Oracle Jdk, Oracle Jre.

## How do I fix CVE-2022-21549?

Upgrade java to 17.0.4 or later.

## Is CVE-2022-21549 being exploited?

There is no known exploitation of CVE-2022-21549 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2022-21449](https://insights.sbomify.com/CVE-2022-21449/): Other in Java SE JDK and JRE (high 7.5)
- [CVE-2022-21476](https://insights.sbomify.com/CVE-2022-21476/): Information disclosure in Java SE JDK and JRE (high 7.5)
- [CVE-2022-21541](https://insights.sbomify.com/CVE-2022-21541/): Other in Java SE JDK and JRE (medium 5.9)
- [CVE-2023-21830](https://insights.sbomify.com/CVE-2023-21830/): Deserialization in Java SE JDK and JRE (medium 5.3)
- [CVE-2023-21835](https://insights.sbomify.com/CVE-2023-21835/): Denial of service in Java SE JDK and JRE (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21549 and fix it if it is affected.

What it is: CVE-2022-21549 is a medium-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21549 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected from 12.0.0; fixed in 17.0.4
- java-min (Bitnami): affected from 12.0.0; fixed in 17.0.4
- jre (Bitnami): affected from 12.0.0; fixed in 17.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21549/ (Markdown: https://insights.sbomify.com/CVE-2022-21549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21549
- OSV: https://osv.dev/vulnerability/CVE-2022-21549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21549/
Summaries are generated and may contain mistakes; the official description above is the record.
