CVE-2022-21595 Denial of service in MySQL Server
A high-privileged attacker can cause a complete denial of service in MySQL Server via the C API component.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-21595?
CVE-2022-21595 is a medium-severity denial of service vulnerability in Mariadb Mariadb, published on 18 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Vulnerability in the MySQL Server product of Oracle MySQL (component: C API). Supported versions that are affected are 5.7.36 and prior and 8.0.27 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).
Which versions are affected by CVE-2022-21595?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
mariadb-min Bitnami | All versions | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
mysql-client Bitnami | All versions | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
Products include Mariadb Mariadb, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Oracle Mysql.
How do I fix CVE-2022-21595?
Upgrade mariadb to a fixed version for your release line: 10.2.42, 10.3.33, 10.4.23 or 10.5.14.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-21595 being exploited?
There is no known exploitation of CVE-2022-21595 in the wild and no public exploit code.
Other vulnerabilities in Mariadb Mariadb
- CVE-2026-49261 MariaDB server has unsafe parameter handling in `wsrep_notify_cmd`
- CVE-2026-85746 MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections
- CVE-2026-85748 MariaDB: Use-after-free with a large number of SYS_REFCURSOR's
- CVE-2026-92262 MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass.
- CVE-2023-26785 Code injection in n/a
Sources
Also known as BIT-mariadb-2022-21595, BIT-mariadb-min-2022-21595, BIT-mysql-client-2022-21595, GHSA-cvq4-rgf9-fp77, UBUNTU-CVE-2022-21595.