# CVE-2022-21595: Denial of service in MySQL Server

> A high-privileged attacker can cause a complete denial of service in MySQL Server via the C API component.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Oct 2022
- **Updated:** 24 Sep 2024
- **Also known as:** BIT-mariadb-2022-21595, BIT-mariadb-min-2022-21595, BIT-mysql-client-2022-21595, GHSA-cvq4-rgf9-fp77, UBUNTU-CVE-2022-21595

## What is CVE-2022-21595?

CVE-2022-21595 is a medium-severity denial of service vulnerability in Mariadb Mariadb, published on 18 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Vulnerability in the MySQL Server product of Oracle MySQL (component: C API). Supported versions that are affected are 5.7.36 and prior and 8.0.27 and prior. Difficult to exploit vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.4 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H).

## Which versions are affected by CVE-2022-21595?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | All versions | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
| `mariadb-min` | Bitnami | All versions | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |
| `mysql-client` | Bitnami | All versions | 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2 |

Products: Mariadb Mariadb, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Oracle Mysql.

## How do I fix CVE-2022-21595?

Upgrade mariadb to a fixed version for your release line: 10.2.42, 10.3.33, 10.4.23 or 10.5.14.

## Is CVE-2022-21595 being exploited?

There is no known exploitation of CVE-2022-21595 in the wild and no public exploit code.

## Other vulnerabilities in Mariadb Mariadb

- [CVE-2026-49261](https://insights.sbomify.com/CVE-2026-49261/): MariaDB server has unsafe parameter handling in `wsrep_notify_cmd` (critical 10.0)
- [CVE-2026-85746](https://insights.sbomify.com/CVE-2026-85746/): MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections (critical 9.9)
- [CVE-2026-85748](https://insights.sbomify.com/CVE-2026-85748/): MariaDB: Use-after-free with a large number of SYS_REFCURSOR's (critical 9.9)
- [CVE-2026-92262](https://insights.sbomify.com/CVE-2026-92262/): MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass. (critical 9.9)
- [CVE-2023-26785](https://insights.sbomify.com/CVE-2023-26785/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21595 and fix it if it is affected.

What it is: CVE-2022-21595 is a medium-severity denial of service vulnerability in Mariadb Mariadb, published on 18 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21595 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected all versions; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2
- mariadb-min (Bitnami): affected all versions; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2
- mysql-client (Bitnami): affected all versions; fixed in 10.2.42, 10.3.33, 10.4.23, 10.5.14, 10.6.6, 10.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21595/ (Markdown: https://insights.sbomify.com/CVE-2022-21595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21595
- OSV: https://osv.dev/vulnerability/CVE-2022-21595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21595/
Summaries are generated and may contain mistakes; the official description above is the record.
