CVE-2022-21642 Exposure of whisper participants in discourse

Medium 4.3 Published Updated

An attacker can view private whisper participants in Discourse forums by triggering user suggestions, exposing sensitive membership data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-21642?

CVE-2022-21642 is a medium-severity vulnerability in Discourse Discourse, published on 5 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source platform for community discussion. In affected versions when composing a message from topic the composer user suggestions reveals whisper participants. The issue has been patched in stable version 2.7.13 and beta version 2.8.0.beta11. There is no workaround for this issue and users are advised to upgrade.

Weakness: CWE-200

Which versions are affected by CVE-2022-21642?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.7.13

Products include Discourse Discourse.

How do I fix CVE-2022-21642?

Upgrade discourse to 2.7.13 or later.

Is CVE-2022-21642 being exploited?

There is no known exploitation of CVE-2022-21642 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-21642, GHSA-mx3h-vc7w-r9c6.

Is CVE-2022-21642 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free