# CVE-2022-21646: Lookup operations do not take into account wildcards in SpiceDB

> Attackers can bypass permission checks in SpiceDB when wildcards are used in exclusions or intersections, gaining unauthorized access to resources.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7p8f-8hjm-wm92, GO-2022-0295

## What is CVE-2022-21646?

CVE-2022-21646 is a high-severity vulnerability in authzed spicedb, published on 11 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SpiceDB is a database system for managing security-critical application permissions. Any user making use of a wildcard relationship under the right hand branch of an `exclusion` or within an `intersection` operation will see `Lookup`/`LookupResources` return a resource as "accessible" if it is *not* accessible by virtue of the inclusion of the wildcard in the intersection or the right side of the exclusion. In `v1.3.0`, the wildcard is ignored entirely in lookup's dispatch, resulting in the `banned` wildcard being ignored in the exclusion. Version 1.4.0 contains a patch for this issue. As a workaround, don't make use of wildcards on the right side of intersections or within exclusions.

Weakness: CWE-20 (Improper Input Validation), CWE-155 (Improper Neutralization of Wildcards or Matching Symbols)

## Which versions are affected by CVE-2022-21646?

3 open source packages ship an affected version, including github.com/authzed/spicedb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authzed/spicedb` | Go | From 1.3.0 | 1.4.0 |
| `github.com/authzed/spicedb` | Go | From 1.3.0 | 1.4.0 |
| `github.com/authzed/spicedb` | Go | From 1.3.0 | 1.4.0 |

Products: Authzed Spicedb.

## How do I fix CVE-2022-21646?

Upgrade github.com/authzed/spicedb to 1.4.0 or later.

## Is CVE-2022-21646 being exploited?

There is no known exploitation of CVE-2022-21646 in the wild and no public exploit code.

## Other vulnerabilities in authzed spicedb

- [CVE-2023-29193](https://insights.sbomify.com/CVE-2023-29193/): SpiceDB binding metrics port to untrusted networks and can leak command-line flags (high 8.7)
- [CVE-2024-27101](https://insights.sbomify.com/CVE-2024-27101/): Integer overflow in chunking helper causes dispatching to miss elements or panic (high 7.3)
- [CVE-2026-40091](https://insights.sbomify.com/CVE-2026-40091/): SpiceDB: SPICEDB_DATASTORE_CONN_URI is leaked on startup logs (medium 6.0)
- [CVE-2023-46255](https://insights.sbomify.com/CVE-2023-46255/): `SPICEDB_DATASTORE_CONN_URI` is leaked when URI cannot be parsed (medium 4.2)
- [CVE-2025-49011](https://insights.sbomify.com/CVE-2025-49011/): SpiceDB checks involving relations with caveats can result in no permission when permission is expected (low 3.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-21646 and fix it if it is affected.

What it is: CVE-2022-21646 is a high-severity vulnerability in authzed spicedb, published on 11 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-21646 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authzed/spicedb (Go): affected from 1.3.0; fixed in 1.4.0
- github.com/authzed/spicedb (Go): affected from 1.3.0; fixed in 1.4.0
- github.com/authzed/spicedb (Go): affected from 1.3.0; fixed in 1.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-21646/ (Markdown: https://insights.sbomify.com/CVE-2022-21646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-21646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-21646
- OSV: https://osv.dev/vulnerability/CVE-2022-21646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-21646/
Summaries are generated and may contain mistakes; the official description above is the record.
